]> git.pld-linux.org Git - packages/python-pyatspi.git/blob - python-pyatspi.spec
Add module for python3. Release 2
[packages/python-pyatspi.git] / python-pyatspi.spec
1 %define         module  pyatspi
2 Summary:        AT-SPI Python bindings
3 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona
4 Name:           python-%{module}
5 Version:        2.8.0
6 Release:        2
7 License:        LGPL v2
8 Group:          Development/Languages/Python
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pyatspi/2.8/%{module}-%{version}.tar.xz
10 # Source0-md5:  930f51c62cca60ebdf90f735d26385b2
11 URL:            http://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
12 BuildRequires:  pkgconfig
13 BuildRequires:  python-devel >= 1:2.6
14 BuildRequires:  python-distribute
15 BuildRequires:  python-pygobject3-devel >= 3.0.0
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  xz
19 Requires:       at-spi2-core >= 2.8.0
20 Requires:       gobject-introspection
21 Requires:       python-modules
22 Requires:       python-pygobject3 >= 3.0.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This package provides AT-SPI Python bindings.
27
28 %description -l pl.UTF-8
29 Ten pakiet dostarcza wiązania AT-SPI dla Pythona.
30
31 %package -n python3-%{module}
32 Summary:        AT-SPI Python 3 bindings
33 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona 3
34 Group:          Development/Languages/Python
35 Requires:       at-spi2-core >= 2.8.0
36 Requires:       gobject-introspection
37 Requires:       python3-modules
38 Requires:       python3-pygobject3 >= 3.0.0
39
40 %description -n python3-%{module}
41 This package provides AT-SPI Python 3 bindings.
42
43 %description -n python3-%{module} -l pl.UTF-8
44 Ten pakiet dostarcza wiązania AT-SPI dla Pythona 3.
45
46 %prep
47 %setup -q -n %{module}-%{version}
48
49 %build
50 mkdir py3
51 cd py3
52 ../%configure \
53         --with-python="/usr/bin/python3"
54 %{__make}
55 cd ..
56
57 mkdir py2
58 cd py2
59 ../%configure \
60         --with-python="%{__python}"
61 %{__make}
62 cd ..
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} -C py3 install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %{__make} -C py2 install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc AUTHORS NEWS README
79 %{py_sitescriptdir}/pyatspi
80
81 %files -n python3-%{module}
82 %defattr(644,root,root,755)
83 %{py3_sitescriptdir}/pyatspi
This page took 0.110112 seconds and 3 git commands to generate.