]> git.pld-linux.org Git - packages/python-pyatspi.git/blob - python-pyatspi.spec
6d9705e6c395b3745f03eb900096298a4cd54611
[packages/python-pyatspi.git] / python-pyatspi.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5 #
6 %define         module  pyatspi
7 Summary:        AT-SPI Python bindings
8 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona
9 Name:           python-%{module}
10 Version:        2.38.0
11 Release:        2
12 License:        LGPL v2
13 Group:          Development/Languages/Python
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pyatspi/2.38/%{module}-%{version}.tar.xz
15 # Source0-md5:  7909957aac797725741959078f098ba7
16 URL:            https://wiki.linuxfoundation.org/accessibility/d-bus
17 BuildRequires:  pkgconfig
18 BuildRequires:  python-pygobject3-common-devel >= 3.0.0
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.6
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-devel >= 1:3.2
27 %endif
28 Requires:       at-spi2-core >= 2.12.0
29 Requires:       gobject-introspection
30 Requires:       python-modules
31 Requires:       python-pygobject3 >= 3.0.0
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This package provides AT-SPI Python bindings.
37
38 %description -l pl.UTF-8
39 Ten pakiet dostarcza wiązania AT-SPI dla Pythona.
40
41 %package -n python3-%{module}
42 Summary:        AT-SPI Python 3 bindings
43 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona 3
44 Group:          Development/Languages/Python
45 Requires:       at-spi2-core >= 2.12.0
46 Requires:       gobject-introspection
47 Requires:       python3-modules
48 Requires:       python3-pygobject3 >= 3.0.0
49
50 %description -n python3-%{module}
51 This package provides AT-SPI Python 3 bindings.
52
53 %description -n python3-%{module} -l pl.UTF-8
54 Ten pakiet dostarcza wiązania AT-SPI dla Pythona 3.
55
56 %prep
57 %setup -q -n %{module}-%{version}
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %if %{with python3}
66 mkdir -p py3
67 cd py3
68 ../%configure \
69         --host=%{_host} \
70         --build=%{_build} \
71         --with-python="%{__python3}"
72 %{__make}
73 cd ..
74 %endif
75
76 %if %{with python2}
77 mkdir -p py2
78 cd py2
79 ../%configure \
80         --host=%{_host} \
81         --build=%{_build} \
82         --with-python="%{__python}"
83 %{__make}
84 cd ..
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python3}
91 %{__make} -C py3 install \
92         DESTDIR=$RPM_BUILD_ROOT
93 %endif
94
95 %if %{with python2}
96 %{__make} -C py2 install \
97         DESTDIR=$RPM_BUILD_ROOT
98 %endif
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %if %{with python2}
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS NEWS README
107 %{py_sitescriptdir}/pyatspi
108 %endif
109
110 %if %{with python3}
111 %files -n python3-%{module}
112 %defattr(644,root,root,755)
113 %doc AUTHORS NEWS README
114 %{py3_sitescriptdir}/pyatspi
115 %endif
This page took 0.072288 seconds and 2 git commands to generate.