]> git.pld-linux.org Git - packages/python-pyasn1.git/blob - python-pyasn1.spec
422395f07bd28c396c44ca79d3c5029e228c97e1
[packages/python-pyasn1.git] / python-pyasn1.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  pyasn1
8
9 Summary:        ASN.1 tools for Python
10 Summary(pl.UTF-8):      Narzędzia ASN.1 dla Pythona
11 Name:           python-%{module}
12 Version:        0.1.9
13 Release:        1
14 License:        BSD-like
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.python.org/simple/pyasn1/
17 Source0:        https://pypi.python.org/packages/source/p/pyasn1/%{module}-%{version}.tar.gz
18 # Source0-md5:  f00a02a631d4016818659d1cc38d229a
19 URL:            http://pyasn1.sourceforge.net/
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 %if %{with python2}
22 BuildRequires:  python >= 1:2.5
23 BuildRequires:  python-modules >= 1:2.5
24 %if %{with tests}
25 %if "%{py_ver}" < "2.7"
26 BuildRequires:  python-unittest2
27 %endif
28 %endif
29 %endif
30 %if %{with python3}
31 BuildRequires:  python3 >= 1:3.3
32 BuildRequires:  python3-modules >= 1:3.3
33 %endif
34 BuildRequires:  rpm-pythonprov
35 %pyrequires_eq  python-modules
36 Obsoletes:      python-pyasn1-examples
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This project is dedicated to implementation of ASN.1 types (concrete
42 syntax) and codecs (transfer syntaxes) for Python programming
43 environment.
44
45 %description -l pl.UTF-8
46 Celem tego projektu jest implementacja typów (konkretnej składni) i
47 kodowania (składni przesyłania) ASN.1 dla środowiska programowania
48 Python.
49
50 %package -n python3-%{module}
51 Summary:        ASN.1 tools for Python
52 Summary(pl.UTF-8):      Narzędzia ASN.1 dla Pythona
53 Group:          Libraries/Python
54
55 %description -n python3-%{module}
56 This project is dedicated to implementation of ASN.1 types (concrete
57 syntax) and codecs (transfer syntaxes) for Python programming
58 environment.
59
60 %description -n python3-%{module} -l pl.UTF-8
61 Celem tego projektu jest implementacja typów (konkretnej składni) i
62 kodowania (składni przesyłania) ASN.1 dla środowiska programowania
63 Python.
64
65 %prep
66 %setup -q -n %{module}-%{version}
67
68 %build
69 %if %{with python2}
70 %py_build %{?with_tests:test}
71 %endif
72 %if %{with python3}
73 %py3_build %{?with_tests:test}
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %if %{with python2}
80 %py_install
81
82 %py_postclean
83 %endif
84
85 %if %{with python3}
86 %py3_install
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %if %{with python2}
93 %files
94 %defattr(644,root,root,755)
95 %doc CHANGES.txt LICENSE.txt README.txt THANKS.txt TODO.txt doc/*.html
96 %{py_sitescriptdir}/%{module}
97 %{py_sitescriptdir}/pyasn1-%{version}-py*.egg-info
98 %endif
99
100 %if %{with python3}
101 %files -n python3-%{module}
102 %defattr(644,root,root,755)
103 %doc CHANGES.txt LICENSE.txt README.txt THANKS.txt TODO.txt doc/*.html
104 %{py3_sitescriptdir}/%{module}
105 %{py3_sitescriptdir}/pyasn1-%{version}-py*.egg-info
106 %endif
This page took 0.137623 seconds and 2 git commands to generate.