]> git.pld-linux.org Git - packages/python-pretend.git/blob - python-pretend.spec
rebuild with python 3.10
[packages/python-pretend.git] / python-pretend.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        A library for stubbing in Python 2
7 Summary(pl.UTF-8):      Biblioteka do tworzenia zaślepek w Pythonie 2
8 Name:           python-pretend
9 Version:        1.0.9
10 Release:        4
11 License:        BSD
12 Group:          Development/Languages/Python
13 #Source0Download: https://pypi.org/simple/pretend/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pretend/pretend-%{version}.tar.gz
15 # Source0-md5:  ad53883ede48aeac7ae584f0de0240e8
16 URL:            https://github.com/alex/pretend
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.6
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3.2
25 BuildRequires:  python3-setuptools
26 %endif
27 Requires:       python-modules >= 1:2.6
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Pretend is a library to make stubbing with Python easier.
33
34 %description -l pl.UTF-8
35 Pretend to biblioteka ułatwiająca tworzenie zaślepek w Pythonie.
36
37 %package -n python3-pretend
38 Summary:        A library for stubbing in Python 3
39 Summary(pl.UTF-8):      Biblioteka do tworzenia zaślepek w Pythonie 3
40 Group:          Development/Languages/Python
41 Requires:       python3-modules >= 1:3.2
42
43 %description -n python3-pretend
44 Pretend is a library to make stubbing with Python easier.
45
46 %description -n python3-pretend -l pl.UTF-8
47 Pretend to biblioteka ułatwiająca tworzenie zaślepek w Pythonie.
48
49 %prep
50 %setup -q -n pretend-%{version}
51
52 %build
53 %if %{with python2}
54 %py_build
55 %endif
56
57 %if %{with python3}
58 %py3_build
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %if %{with python2}
65 %py_install
66
67 %py_postclean
68 %endif
69
70 %if %{with python3}
71 %py3_install
72 %endif
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %if %{with python2}
78 %files
79 %defattr(644,root,root,755)
80 %doc LICENSE.rst README.rst
81 %{py_sitescriptdir}/pretend.py[co]
82 %{py_sitescriptdir}/pretend-%{version}-py*.egg-info
83 %endif
84
85 %if %{with python3}
86 %files -n python3-pretend
87 %defattr(644,root,root,755)
88 %doc LICENSE.rst README.rst
89 %{py3_sitescriptdir}/pretend.py
90 %{py3_sitescriptdir}/__pycache__/pretend.cpython-*.py[co]
91 %{py3_sitescriptdir}/pretend-%{version}-py*.egg-info
92 %endif
This page took 0.078055 seconds and 3 git commands to generate.