]> git.pld-linux.org Git - packages/python-peppercorn.git/blob - python-peppercorn.spec
new, version 0.4
[packages/python-peppercorn.git] / python-peppercorn.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  peppercorn
6 Summary:        A library for converting a token stream into a data structure for use in web form posts
7 Name:           python-%{module}
8 Version:        0.4
9 Release:        1
10 License:        BSD-derived (http://www.repoze.org/LICENSE.txt)
11 Group:          Libraries/Python
12 Source0:        http://pypi.python.org/packages/source/p/peppercorn/peppercorn-%{version}.tar.gz
13 # Source0-md5:  464d6f2342eaf704dfb52046c1f5c320
14 URL:            http://docs.pylonsproject.org/projects/peppercorn/
15 BuildRequires:  python-distribute
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 Requires:       python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 A library for converting a token stream into a data structure
24 comprised of sequences, mappings, and scalars, developed primarily for
25 converting HTTP form post data into a richer data structure.
26
27 %prep
28 %setup -q -n %{module}-%{version}
29
30 %build
31 %{__python} setup.py build
32
33 %{?with_tests:%{__python} setup.py test}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %{__python} setup.py install \
38         --skip-build \
39         --optimize=2 \
40         --root=$RPM_BUILD_ROOT
41
42 %{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests.py*
43
44 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
45 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
46 %py_postclean
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc CHANGES.txt LICENSE.txt README.txt
54 %dir %{py_sitescriptdir}/%{module}
55 %{py_sitescriptdir}/%{module}/*.py[co]
56 %{py_sitescriptdir}/%{module}-%{version}*.egg-info
This page took 0.086904 seconds and 4 git commands to generate.