]> git.pld-linux.org Git - packages/python-pefile.git/blob - python-pefile.spec
- disable python3 here
[packages/python-pefile.git] / python-pefile.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_with     python3 # CPython 3.x module (built from python3-pefile.spec)
5
6 Summary:        Python PE parsing module
7 Summary(pl.UTF-8):      Moduł Pythona do analizy PE
8 Name:           python-pefile
9 # keep 2019.x here for python2 support
10 Version:        2019.4.18
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pefile/
15 Source0:        https://files.pythonhosted.org/packages/source/p/pefile/pefile-%{version}.tar.gz
16 # Source0-md5:  e328272bc82ddc3170316250e37027ad
17 URL:            https://pypi.org/project/pefile/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.5
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-modules >= 1:3.2
24 BuildRequires:  python3-setuptools
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python-modules >= 1:2.5
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 pefile is a multi-platform Python module to parse and work with
34 Portable Executable (aka PE) files. Most of the information contained
35 in the PE headers is accessible as well as all sections' details and
36 their data.
37
38 %description -l pl.UTF-8
39 pefile to wieloplatformowy moduł Pythona do analizy i pracy z plikami
40 Portable Executable (PE). Umożliwia dostęp do większości informacji
41 zawartych w nagłówkach PE, a także szczegółów oraz danych wszystkich
42 sekcji.
43
44 %package -n python3-pefile
45 Summary:        Python PE parsing module
46 Summary(pl.UTF-8):      Moduł Pythona do analizy PE
47 Group:          Libraries/Python
48 Requires:       python3-modules >= 1:3.2
49
50 %description -n python3-pefile
51 pefile is a multi-platform Python module to parse and work with
52 Portable Executable (aka PE) files. Most of the information contained
53 in the PE headers is accessible as well as all sections' details and
54 their data.
55
56 %description -n python3-pefile -l pl.UTF-8
57 pefile to wieloplatformowy moduł Pythona do analizy i pracy z plikami
58 Portable Executable (PE). Umożliwia dostęp do większości informacji
59 zawartych w nagłówkach PE, a także szczegółów oraz danych wszystkich
60 sekcji.
61
62 %prep
63 %setup -q -n pefile-%{version}
64
65 %build
66 %if %{with python2}
67 %py_build
68 %endif
69
70 %if %{with python3}
71 %py3_build
72 %endif
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %if %{with python2}
78 %py_install
79
80 %py_postclean
81 %endif
82
83 %if %{with python3}
84 %py3_install
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 %files
92 %defattr(644,root,root,755)
93 %doc LICENSE README
94 %{py_sitescriptdir}/ordlookup
95 %{py_sitescriptdir}/pefile.py[co]
96 %{py_sitescriptdir}/peutils.py[co]
97 %{py_sitescriptdir}/pefile-%{version}-py*.egg-info
98 %endif
99
100 %if %{with python3}
101 %files -n python3-pefile
102 %defattr(644,root,root,755)
103 %doc LICENSE README
104 %{py3_sitescriptdir}/ordlookup
105 %{py3_sitescriptdir}/pefile.py
106 %{py3_sitescriptdir}/peutils.py
107 %{py3_sitescriptdir}/__pycache__/pefile.cpython-*.py[co]
108 %{py3_sitescriptdir}/__pycache__/peutils.cpython-*.py[co]
109 %{py3_sitescriptdir}/pefile-%{version}-py*.egg-info
110 %endif
This page took 0.107024 seconds and 3 git commands to generate.