]> git.pld-linux.org Git - packages/python-pebble.git/blob - python-pebble.spec
- new
[packages/python-pebble.git] / python-pebble.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Threading and multiprocessing eye-candy
8 Summary(pl.UTF-8):      Miłe dla oka wątli i wieloprocesowość
9 Name:           python-pebble
10 Version:        4.4.0
11 Release:        1
12 License:        LGPL v3+
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pebble/
15 Source0:        https://files.pythonhosted.org/packages/source/p/pebble/Pebble-%{version}.tar.gz
16 # Source0-md5:  c8c06548a13af018bfa247ae1ecdd844
17 URL:            https://pypi.org/project/Pebble/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.5
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-futures
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules >= 1:3.2
29 BuildRequires:  python3-setuptools
30 %endif
31 Requires:       python-modules >= 1:2.5
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Pebble provides a neat API to manage threads and processes within an
37 application.
38
39 %description -l pl.UTF-8
40 Pebble udostępnia schludne API do zarządzania wątkami i procesami
41 wewnątrz aplikacji.
42
43 %package -n python3-pebble
44 Summary:        Threading and multiprocessing eye-candy
45 Summary(pl.UTF-8):      Miłe dla oka wątli i wieloprocesowość
46 Group:          Libraries/Python
47 Requires:       python3-modules >= 1:3.2
48
49 %description -n python3-pebble
50 Pebble provides a neat API to manage threads and processes within an
51 application.
52
53 %description -n python3-pebble -l pl.UTF-8
54 Pebble udostępnia schludne API do zarządzania wątkami i procesami
55 wewnątrz aplikacji.
56
57 %prep
58 %setup -q -n Pebble-%{version}
59
60 %build
61 %if %{with python2}
62 %py_build
63
64 %if %{with tests}
65 %{__python} -m unittest discover -s test
66 %endif
67 %endif
68
69 %if %{with python3}
70 %py3_build
71
72 %if %{with tests}
73 %{__python3} -m unittest discover -s test
74 %endif
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with python2}
81 %py_install
82
83 %py_postclean
84 %endif
85
86 %if %{with python3}
87 %py3_install
88 %endif
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %if %{with python2}
94 %files
95 %defattr(644,root,root,755)
96 %doc README.rst
97 %{py_sitescriptdir}/pebble
98 %{py_sitescriptdir}/Pebble-%{version}-py*.egg-info
99 %endif
100
101 %if %{with python3}
102 %files -n python3-pebble
103 %defattr(644,root,root,755)
104 %doc README.rst
105 %{py3_sitescriptdir}/pebble
106 %{py3_sitescriptdir}/Pebble-%{version}-py*.egg-info
107 %endif
This page took 0.161822 seconds and 3 git commands to generate.