]> git.pld-linux.org Git - packages/python-pandas.git/blob - python-pandas.spec
- initial
[packages/python-pandas.git] / python-pandas.spec
1 # TODO: finish apidocs and tests
2 #
3 # Conditional build:
4 %bcond_with     doc     # Sphinx documentation
5 %bcond_with     tests   # unit tests [R: python-zoneinfo for hypothesis?]
6 %bcond_without  python2 # CPython 2.x module
7 %bcond_without  python3 # CPython 3.x module
8
9 Summary:        Powerful data structures for data analysis, time series and statistics
10 Summary(pl.UTF-8):      Elastyczne struktury danych do analizy danych, szeregów chronologicznych i statystyki
11 Name:           python-pandas
12 # keep 0.24.x here for python2 support
13 Version:        0.24.2
14 Release:        1
15 License:        BSD
16 Group:          Libraries/Python
17 #Source0Download: https://pypi.org/simple/pandas/
18 Source0:        https://files.pythonhosted.org/packages/source/p/pandas/pandas-%{version}.tar.gz
19 # Source0-md5:  6640de14a934a701129b635c6d75801d
20 URL:            https://pypi.org/project/pandas/
21 %if %{with python2}
22 BuildRequires:  python-Cython >= 0.28.2
23 BuildRequires:  python-devel >= 1:2.7
24 BuildRequires:  python-numpy-devel >= 1.12.0
25 BuildRequires:  python-setuptools
26 %if %{with tests}
27 BuildRequires:  python-dateutil >= 2.5.0
28 BuildRequires:  python-pytest
29 BuildRequires:  python-pytz >= 2011k
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-Cython >= 0.28.2
34 BuildRequires:  python3-devel >= 1:3.5
35 BuildRequires:  python3-numpy-devel >= 1.12.0
36 BuildRequires:  python3-setuptools
37 %if %{with tests}
38 BuildRequires:  python3-dateutil >= 2.5.0
39 BuildRequires:  python3-pytest
40 BuildRequires:  python3-pytz >= 2011k
41 %endif
42 %endif
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.714
45 %if %{with doc}
46 BuildRequires:  sphinx-pdg
47 BuildRequires:  python3-docutils
48 BuildRequires:  python3-nbconvert
49 BuildRequires:  python3-nbsphinx
50 %endif
51 Requires:       python-modules >= 1:2.7
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 pandas is a Python package providing fast, flexible, and expressive
56 data structures designed to make working with structured (tabular,
57 multidimensional, potentially heterogeneous) and time series data both
58 easy and intuitive. It aims to be the fundamental high-level building
59 block for doing practical, real world data analysis in Python.
60 Additionally, it has the broader goal of becoming the most powerful
61 and flexible open source data analysis/manipulation tool available in
62 any language. It is already well on its way toward this goal.
63
64 %description -l pl.UTF-8
65 pandas to pakiet Pythona zapewniający szybkie, elastyczne i wyraziste
66 struktury danych, zaprojektowane w celu uczynienia pracy z danymi
67 strukturalnymi (tabelarycznymi, wielowymiarowymi, potencjalnie
68 heterogenicznymi) oraz szeregami chronologicznymi łatwiejszą i
69 bardziej intyicyjną. Celem projektu jest pozycja podstawowego bloku
70 wysokopoziomowego do praktycznej analizy rzeczywistych danych w
71 Pythonie. Dodatkowym, szerszym celem jest pozycja najbardziej
72 funkcjonalnego i elastycznego narzędzia o otwartych źródłach,
73 służącego do analizy i obróbki danych niezależnie od języka.
74
75 %package -n python3-pandas
76 Summary:        Powerful data structures for data analysis, time series and statistics
77 Summary(pl.UTF-8):      Elastyczne struktury danych do analizy danych, szeregów chronologicznych i statystyki
78 Group:          Libraries/Python
79 Requires:       python3-modules >= 1:3.5
80
81 %description -n python3-pandas
82 pandas is a Python package providing fast, flexible, and expressive
83 data structures designed to make working with structured (tabular,
84 multidimensional, potentially heterogeneous) and time series data both
85 easy and intuitive. It aims to be the fundamental high-level building
86 block for doing practical, real world data analysis in Python.
87 Additionally, it has the broader goal of becoming the most powerful
88 and flexible open source data analysis/manipulation tool available in
89 any language. It is already well on its way toward this goal.
90
91 %description -n python3-pandas -l pl.UTF-8
92 pandas to pakiet Pythona zapewniający szybkie, elastyczne i wyraziste
93 struktury danych, zaprojektowane w celu uczynienia pracy z danymi
94 strukturalnymi (tabelarycznymi, wielowymiarowymi, potencjalnie
95 heterogenicznymi) oraz szeregami chronologicznymi łatwiejszą i
96 bardziej intyicyjną. Celem projektu jest pozycja podstawowego bloku
97 wysokopoziomowego do praktycznej analizy rzeczywistych danych w
98 Pythonie. Dodatkowym, szerszym celem jest pozycja najbardziej
99 funkcjonalnego i elastycznego narzędzia o otwartych źródłach,
100 służącego do analizy i obróbki danych niezależnie od języka.
101
102 %package apidocs
103 Summary:        API documentation for Python pandas module
104 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona pandas
105 Group:          Documentation
106 %if "%{_rpmversion}" >= "4.6"
107 BuildArch:      noarch
108 %endif
109
110 %description apidocs
111 API documentation for Python pandas module.
112
113 %description apidocs -l pl.UTF-8
114 Dokumentacja API modułu Pythona pandas.
115
116 %prep
117 %setup -q -n pandas-%{version}
118
119 %build
120 %if %{with python2}
121 %py_build
122
123 %if %{with tests}
124 cd build-2/lib.*
125 %{__python} -m pytest pandas
126 cd ../..
127 %endif
128 %endif
129
130 %if %{with python3}
131 %py3_build
132
133 %if %{with tests}
134 cd build-3/lib.*
135 %{__python3} -m pytest pandas
136 cd ../..
137 %endif
138 %endif
139
140 %if %{with doc}
141 cd doc
142 %{__python3} make.py --python-path=$(readlink -f ../build-3/lib.*) html
143 %endif
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %if %{with python2}
149 %py_install
150
151 %{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/pandas/tests
152 %py_postclean
153 %endif
154
155 %if %{with python3}
156 %py3_install
157
158 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/pandas/tests
159 %endif
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %if %{with python2}
165 %files
166 %defattr(644,root,root,755)
167 %doc LICENSE README.md RELEASE.md
168 %dir %{py_sitedir}/pandas
169 %{py_sitedir}/pandas/*.py[co]
170 %dir %{py_sitedir}/pandas/_libs
171 %attr(755,root,root) %{py_sitedir}/pandas/_libs/*.so
172 %{py_sitedir}/pandas/_libs/__init__.py[co]
173 %dir %{py_sitedir}/pandas/_libs/tslibs
174 %attr(755,root,root) %{py_sitedir}/pandas/_libs/tslibs/*.so
175 %{py_sitedir}/pandas/_libs/tslibs/__init__.py[co]
176 %{py_sitedir}/pandas/api
177 %{py_sitedir}/pandas/arrays
178 %{py_sitedir}/pandas/compat
179 %{py_sitedir}/pandas/core
180 %{py_sitedir}/pandas/errors
181 %dir %{py_sitedir}/pandas/io
182 %{py_sitedir}/pandas/io/*.py[co]
183 %{py_sitedir}/pandas/io/clipboard
184 %{py_sitedir}/pandas/io/formats
185 %{py_sitedir}/pandas/io/json
186 %dir %{py_sitedir}/pandas/io/msgpack
187 %attr(755,root,root) %{py_sitedir}/pandas/io/msgpack/_*.so
188 %{py_sitedir}/pandas/io/msgpack/*.py[co]
189 %dir %{py_sitedir}/pandas/io/sas
190 %attr(755,root,root) %{py_sitedir}/pandas/io/sas/_sas.so
191 %{py_sitedir}/pandas/io/sas/*.py[co]
192 %{py_sitedir}/pandas/plotting
193 %{py_sitedir}/pandas/tseries
194 %dir %{py_sitedir}/pandas/util
195 %attr(755,root,root) %{py_sitedir}/pandas/util/_move.so
196 %{py_sitedir}/pandas/util/*.py[co]
197 %{py_sitedir}/pandas-%{version}-py*.egg-info
198 %endif
199
200 %if %{with python3}
201 %files -n python3-pandas
202 %defattr(644,root,root,755)
203 %doc LICENSE README.md RELEASE.md
204 %dir %{py3_sitedir}/pandas
205 %{py3_sitedir}/pandas/*.py
206 %{py3_sitedir}/pandas/__pycache__
207 %dir %{py3_sitedir}/pandas/_libs
208 %attr(755,root,root) %{py3_sitedir}/pandas/_libs/*.cpython-*.so
209 %{py3_sitedir}/pandas/_libs/__init__.py
210 %{py3_sitedir}/pandas/_libs/__pycache__
211 %dir %{py3_sitedir}/pandas/_libs/tslibs
212 %attr(755,root,root) %{py3_sitedir}/pandas/_libs/tslibs/*.cpython-*.so
213 %{py3_sitedir}/pandas/_libs/tslibs/__init__.py
214 %{py3_sitedir}/pandas/_libs/tslibs/__pycache__
215 %{py3_sitedir}/pandas/api
216 %{py3_sitedir}/pandas/arrays
217 %{py3_sitedir}/pandas/compat
218 %{py3_sitedir}/pandas/core
219 %{py3_sitedir}/pandas/errors
220 %dir %{py3_sitedir}/pandas/io
221 %{py3_sitedir}/pandas/io/*.py
222 %{py3_sitedir}/pandas/io/__pycache__
223 %{py3_sitedir}/pandas/io/clipboard
224 %{py3_sitedir}/pandas/io/formats
225 %{py3_sitedir}/pandas/io/json
226 %dir %{py3_sitedir}/pandas/io/msgpack
227 %attr(755,root,root) %{py3_sitedir}/pandas/io/msgpack/_*.cpython-*.so
228 %{py3_sitedir}/pandas/io/msgpack/*.py
229 %{py3_sitedir}/pandas/io/msgpack/__pycache__
230 %dir %{py3_sitedir}/pandas/io/sas
231 %attr(755,root,root) %{py3_sitedir}/pandas/io/sas/_sas.cpython-*.so
232 %{py3_sitedir}/pandas/io/sas/*.py
233 %{py3_sitedir}/pandas/io/sas/__pycache__
234 %{py3_sitedir}/pandas/plotting
235 %{py3_sitedir}/pandas/tseries
236 %dir %{py3_sitedir}/pandas/util
237 %attr(755,root,root) %{py3_sitedir}/pandas/util/_move.cpython-*.so
238 %{py3_sitedir}/pandas/util/*.py
239 %{py3_sitedir}/pandas/util/__pycache__
240 %{py3_sitedir}/pandas-%{version}-py*.egg-info
241 %endif
242
243 %if %{with doc}
244 %files apidocs
245 %defattr(644,root,root,755)
246 # TODO: actual apidocs
247 %doc doc/cheatsheet/Pandas_Cheat_Sheet.pdf
248 %lang(ja) %doc doc/cheatsheet/Pandas_Cheat_Sheet_JA.pdf
249 %endif
This page took 0.100273 seconds and 3 git commands to generate.