]> git.pld-linux.org Git - packages/python-oyoyo.git/blob - python-oyoyo.spec
- new
[packages/python-oyoyo.git] / python-oyoyo.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Fast, simple IRC module suitable for clients, bots and games
7 Summary(pl.UTF-8):      Szybki, prosty moduł IRC odpowiedni dla klientów, botów i gier
8 Name:           python-oyoyo
9 Version:        0.0.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/oyoyo/
14 Source0:        https://files.pythonhosted.org/packages/source/o/oyoyo/oyoyo-%{version}dev.tar.gz
15 # Source0-md5:  ab5d74a96de284239cc0624dd5c1f8b5
16 URL:            https://pypi.org/project/oyoyo/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.5
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-2to3 >= 1:3.2
23 BuildRequires:  python3-modules >= 1:3.2
24 BuildRequires:  python3-setuptools
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python-modules >= 1:2.5
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The oyoyo IRC library is a small, simple IRC lib for Python suitable
34 for bots, clients and anything else you can think of (even games).
35
36 %description -l pl.UTF-8
37 Biblioteka IRC oyoyo to mała, prosta biblioteka dla Pythona, nadająca
38 się na potrzeby botów, klientów i czegokolwiek innego (nawet gier).
39
40 %package -n python3-oyoyo
41 Summary:        Fast, simple IRC module suitable for clients, bots and games
42 Summary(pl.UTF-8):      Szybki, prosty moduł IRC odpowiedni dla klientów, botów i gier
43 Group:          Libraries/Python
44 Requires:       python3-modules >= 1:3.2
45
46 %description -n python3-oyoyo
47 The oyoyo IRC library is a small, simple IRC lib for Python suitable
48 for bots, clients and anything else you can think of (even games).
49
50 %description -n python3-oyoyo -l pl.UTF-8
51 Biblioteka IRC oyoyo to mała, prosta biblioteka dla Pythona, nadająca
52 się na potrzeby botów, klientów i czegokolwiek innego (nawet gier).
53
54 %prep
55 %setup -q -n oyoyo-%{version}dev
56
57 %build
58 %if %{with python2}
59 %py_build
60 %endif
61
62 %if %{with python3}
63 %py3_build
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python2}
70 %py_install
71
72 %py_postclean
73 %endif
74
75 %if %{with python3}
76 %py3_install
77 %endif
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %if %{with python2}
83 %files
84 %defattr(644,root,root,755)
85 %doc README
86 %{py_sitescriptdir}/oyoyo
87 %{py_sitescriptdir}/oyoyo-%{version}.dev0-py*.egg-info
88 %endif
89
90 %if %{with python3}
91 %files -n python3-oyoyo
92 %defattr(644,root,root,755)
93 %doc README
94 %{py3_sitescriptdir}/oyoyo
95 %{py3_sitescriptdir}/oyoyo-%{version}.dev0-py*.egg-info
96 %endif
This page took 0.069997 seconds and 3 git commands to generate.