]> git.pld-linux.org Git - packages/python-oslo.serialization.git/blob - python-oslo.serialization.spec
rebuild with python 3.10
[packages/python-oslo.serialization.git] / python-oslo.serialization.spec
1 #
2 # Conditional build:
3 %bcond_with     doc     # do build doc (missing deps)
4 %bcond_with     tests   # do perform "make test" (missing deps)
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 Summary:        Oslo Serialization library
9 Name:           python-oslo.serialization
10 Version:        2.27.0
11 Release:        5
12 License:        Apache
13 Group:          Libraries/Python
14 Source0:        https://files.pythonhosted.org/packages/source/o/oslo.serialization/oslo.serialization-%{version}.tar.gz
15 # Source0-md5:  2b8d57696687f69929c1fa41ba490a26
16 URL:            https://pypi.python.org/pypi/oslo.serialization
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-pbr >= 2.0.0
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python-pbr >= 2.0.0
25 BuildRequires:  python3-setuptools
26 %endif
27 Requires:       python-msgpack >= 0.4.0
28 Requires:       python-oslo.utils >= 3.20.0
29 Requires:       python-pbr >= 2.0.0
30 Requires:       python-pytz >= 2013.6
31 Requires:       python-six >= 1.9.0
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The oslo.serialization library provides support for representing
37 objects in transmittable and storable formats, such as Base64, JSON
38 and MessagePack.
39
40 %package -n python3-oslo.serialization
41 Summary:        Oslo Serialization library
42 Group:          Libraries/Python
43 Requires:       python3-msgpack >= 0.4.0
44 Requires:       python3-oslo.utils >= 3.20.0
45 Requires:       python3-pbr >= 2.0.0
46 Requires:       python3-pytz >= 2013.6
47 Requires:       python3-six >= 1.9.0
48
49 %description -n python3-oslo.serialization
50 The oslo.serialization library provides support for representing
51 objects in transmittable and storable formats, such as Base64, JSON
52 and MessagePack.
53
54 %package apidocs
55 Summary:        API documentation for Python oslo.serialization module
56 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona oslo.serialization
57 Group:          Documentation
58
59 %description apidocs
60 API documentation for Pythona oslo.serialization module.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API modułu Pythona oslo.serialization.
64
65 %prep
66 %setup -q -n oslo.serialization-%{version}
67
68 %build
69 %if %{with python2}
70 %py_build %{?with_tests:test}
71 %endif
72
73 %if %{with python3}
74 %py3_build %{?with_tests:test}
75 %endif
76
77 %if %{with doc}
78 cd doc
79 %{__make} -j1 html
80 rm -rf _build/html/_sources
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %if %{with python2}
87 %py_install
88
89 %py_postclean
90 %endif
91
92 %if %{with python3}
93 %py3_install
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %if %{with python2}
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog README.rst
103 %{py_sitescriptdir}/oslo_serialization
104 %{py_sitescriptdir}/oslo.serialization-%{version}-py*.egg-info
105 %endif
106
107 %if %{with python3}
108 %files -n python3-oslo.serialization
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog README.rst
111 %{py3_sitescriptdir}/oslo_serialization
112 %{py3_sitescriptdir}/oslo.serialization-%{version}-py*.egg-info
113 %endif
114
115 %if %{with doc}
116 %files apidocs
117 %defattr(644,root,root,755)
118 %doc doc/_build/html/*
119 %endif
This page took 0.280994 seconds and 3 git commands to generate.