]> git.pld-linux.org Git - packages/python-osc.git/blob - python-osc.spec
rebuild with tests and docs
[packages/python-osc.git] / python-osc.spec
1 #
2 #
3 # Conditional build:
4 %bcond_without  tests   # unit tests
5
6 %define         module          pythonosc
7 %define         egg_name        python_osc
8 %define         pypi_name       python-osc
9 Summary:        Open Sound Control server and client implementations in pure Python
10 Name:           python-osc
11 Version:        1.7.0
12 Release:        6
13 License:        public domain
14 Group:          Libraries/Python
15 Source0:        https://files.pythonhosted.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  d2d72048be1c98c226e55a62e284b976
17 URL:            https://github.com/attwad/python-osc
18 BuildRequires:  python3-modules
19 BuildRequires:  python3-setuptools
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Open Sound Control server and client implementations in pure Python.
27
28 %package -n python3-osc
29 Summary:        Open Sound Control server and client implementations in pure Python
30 Group:          Libraries/Python
31 Requires:       python3-modules
32
33 %description -n python3-osc
34 Open Sound Control server and client implementations in pure Python.
35
36 %prep
37 %setup -q -n %{pypi_name}-%{version}
38
39 %build
40 %py3_build %{?with_tests:test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %py3_install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files -n python3-osc
51 %defattr(644,root,root,755)
52 %doc LICENSE.txt README.rst
53 %{py3_sitescriptdir}/%{module}
54 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.090691 seconds and 3 git commands to generate.