]> git.pld-linux.org Git - packages/python-onedrive.git/blob - python-onedrive.spec
renamed to onedrive in 14.04.1
[packages/python-onedrive.git] / python-onedrive.spec
1 %define         pypi_name       onedrive
2 Summary:        Python and command-line interface for Microsoft LiveConnect OneDrive REST API v5.0
3 Name:           python-%{pypi_name}
4 Version:        14.04.3
5 Release:        1
6 License:        WTFPL
7 Group:          Libraries/Python
8 Source0:        https://pypi.python.org/packages/source/p/python-onedrive/%{name}-%{version}.tar.gz
9 # Source0-md5:  2da74c0fe68452bc84dd050617a33b3e
10 URL:            https://github.com/mk-fg/python-onedrive
11 BuildRequires:  python-devel
12 Suggests:       python-PyYAML
13 Suggests:       python-chardet
14 Suggests:       python-requests >= 0.14.0
15 Obsoletes:      python-skydrive < 14.04.1
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Python and command-line interface for `OneDrive API (version 5.0)
21 (formerly known as SkyDrive).
22
23 This module allows to access data on Microsoft OneDrive cloud storage
24 from Python code, abstracting authentication, HTTP requests and
25 response processing to a simple Python methods.
26
27 %prep
28 %setup -q
29
30 %build
31 %{__python} setup.py build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 %{__python} setup.py install \
36         --skip-build \
37         --optimize=2 \
38         --root=$RPM_BUILD_ROOT
39
40 %py_postclean
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc README.txt
48 %attr(755,root,root) %{_bindir}/onedrive-cli
49 %{py_sitescriptdir}/onedrive
50 %{py_sitescriptdir}/python_onedrive-%{version}-py*.egg-info
This page took 0.130333 seconds and 3 git commands to generate.