]> git.pld-linux.org Git - packages/python-onedrive.git/blob - python-onedrive.spec
14.04.0 version, using old skydrive module name
[packages/python-onedrive.git] / python-onedrive.spec
1 %define         pypi_name       onedrive
2 Summary:        Python and command-line interface for Microsoft LiveConnect OneDrive REST API v5.0
3 Name:           python-%{pypi_name}
4 Version:        14.04.0
5 Release:        1
6 License:        WTFPL
7 Group:          Libraries/Python
8 Source0:        https://github.com/mk-fg/python-onedrive/archive/v%{version}/python-skydrive-%{version}.tar.gz
9 # Source0-md5:  c53d7e380816e5b198ddb46e8956d5d4
10 URL:            https://github.com/mk-fg/python-onedrive
11 BuildRequires:  python-devel
12 Suggests:       python-PyYAML
13 Suggests:       python-chardet
14 Suggests:       python-requests >= 0.14.0
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Python and command-line interface for `OneDrive API (version 5.0)
20 (formerly known as SkyDrive).
21
22 This module allows to access data on Microsoft OneDrive cloud storage
23 from Python code, abstracting authentication, HTTP requests and
24 response processing to a simple Python methods.
25
26 %prep
27 %setup -q
28
29 %build
30 %{__python} setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 %{__python} setup.py install \
35         --skip-build \
36         --optimize=2 \
37         --root=$RPM_BUILD_ROOT
38
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc README.md
47 %attr(755,root,root) %{_bindir}/skydrive-cli
48 %{py_sitescriptdir}/skydrive
49 %{py_sitescriptdir}/python_skydrive-%{version}-py*.egg-info
This page took 0.263399 seconds and 3 git commands to generate.