]> git.pld-linux.org Git - packages/python-objgraph.git/blob - python-objgraph.spec
automatic change: use py_build/py_install macros
[packages/python-objgraph.git] / python-objgraph.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  objgraph
6 Summary:        Draws Python object reference graphs with graphviz
7 Summary(pl.UTF-8):      Rysuje referencje pomiedzy obiektamiy przy uzyciu graphviz
8 Name:           python-objgraph
9 Version:        1.7.1
10 Release:        1
11 License:        MIT
12 Group:          Development/Languages/Python
13 # http://pypi.python.org/packages/source/o/objgraph/objgraph-1.7.1.tar.gz#md5=f6c501b68239e3063b05ca01041652d0
14 Source0:        http://pypi.python.org/packages/source/o/%{module}/%{module}-%{version}.tar.gz
15 # Source0-md5:  f6c501b68239e3063b05ca01041652d0
16 URL:            http://mg.pov.lt/objgraph/
17 BuildRequires:  python-devel
18 BuildRequires:  python-distribute
19 BuildRequires:  rpm-pythonprov
20 # remove BR: python-devel for 'noarch' packages.
21 # if py_postclean is used
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 #Requires:              python-libs
24 Requires:       python-modules
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Module that lets you visually explore Python object graphs.
30
31
32 %description -l pl.UTF-8
33 Moduł do wizualizacji grafów pythonowych obiektów.
34
35 %prep
36 %setup -q -n %{module}-%{version}
37
38 # fix #!%{_bindir}/env python -> #!%{__python}:
39 # %{__sed} -i -e '1s,^#!.*python,#!%{__python},' %{name}.py
40
41 %build
42 # CC/CFLAGS is only for arch packages - remove on noarch packages
43 # CC="%{__cc}" \
44 # %py_build
45
46 %{?with_tests:%{__python} setup.py test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %py_install
51
52 # install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 # cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 # change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
56 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
57 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
58 %py_postclean
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 # %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
66 # change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
67 # %{py_sitedir}/*.py[co]
68 %{py_sitescriptdir}/*.py[co]
69
70 # %attr(755,root,root) %{py_sitedir}/*.so
71 %if "%{py_ver}" > "2.4"
72 %{py_sitescriptdir}/%{module}-*.egg-info
73 %endif
74 # %{_examplesdir}/%{name}-%{version}
This page took 0.090469 seconds and 4 git commands to generate.