]> git.pld-linux.org Git - packages/python-objgraph.git/blob - python-objgraph.spec
72b70c70d7bcfc3630949a158425bd2b83b52508
[packages/python-objgraph.git] / python-objgraph.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  objgraph
8 Summary:        Draws Python object reference graphs with graphviz
9 Summary(pl.UTF-8):      Rysuje referencje pomiedzy obiektamiy przy uzyciu graphviz
10 Name:           python-objgraph
11 Version:        3.4.0
12 Release:        3
13 License:        MIT
14 Group:          Development/Languages/Python
15 Source0:        https://files.pythonhosted.org/packages/source/o/%{module}/%{module}-%{version}.tar.gz
16 # Source0-md5:  cbe527c7dc095a41458d86cab2059591
17 URL:            http://mg.pov.lt/objgraph/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-setuptools
25 %endif
26 %if %{with tests}
27 BuildRequires:  graphviz
28 %endif
29 Requires:       python-modules
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 # optional dependency
34 %define _noautoreq pythonegg.graphviz python3egg.graphviz
35
36 %description
37 Module that lets you visually explore Python object graphs and debug
38 memory leaks.
39
40 %description -l pl.UTF-8
41 Moduł do wizualizacji grafów pythonowych obiektów i debugowania
42 wycieków pamięci.
43
44 %package -n python3-%{module}
45 Summary:        Draws Python object reference graphs with graphviz
46 Summary(pl.UTF-8):      Rysuje referencje pomiedzy obiektamiy przy uzyciu graphviz
47 Group:          Development/Languages/Python
48 Requires:       python3-modules
49
50 %description -n python3-%{module}
51 Module that lets you visually explore Python object graphs and debug
52 memory leaks.
53
54 %description -n python3-%{module} -l pl.UTF-8
55 Moduł do wizualizacji grafów pythonowych obiektów i debugowania
56 wycieków pamięci.
57
58 %prep
59 %setup -q -n %{module}-%{version}
60
61 %build
62 %if %{with python2}
63 %py_build %{?with_tests:test}
64 %endif
65
66 %if %{with python3}
67 %py3_build %{?with_tests:test}
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %if %{with python2}
74 %py_install
75
76 %py_postclean
77 %endif
78
79 %if %{with python3}
80 %py3_install
81 %endif
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGES.rst README.rst docs
86 %{py_sitescriptdir}/%{module}.py*
87 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
88
89 %files -n python3-%{module}
90 %defattr(644,root,root,755)
91 %doc CHANGES.rst README.rst docs
92 %{py3_sitescriptdir}/%{module}.py
93 %{py3_sitescriptdir}/__pycache__/%{module}.*
94 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
This page took 0.065761 seconds and 2 git commands to generate.