]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- fixed requires
[packages/python-numpy.git] / python-numpy.spec
1
2 %define module numpy
3 %define mname Numeric
4
5 %define python_ver      %(echo `python -c "import sys; print (sys.version[:3])"`)
6 %define python_sitepkgsdir      %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
7 %define python_compile_opt python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1])"
8 %define python_compile python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1])"
9
10 Summary:        Python numerical facilities 
11 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
12 Name:           python-%{module}
13 Version:        20.1.0b2
14 Release:        1
15 Copyright:      Distributable
16 Group:          Development/Languages/Python
17 Group(de):      Entwicklung/Sprachen/Python
18 Group(pl):      Programowanie/Jêzyki/Python
19 Source0:        http://prdownloads.sourceforge.net/numpy/%{mname}-%{version}.tar.gz
20 URL:            http://www.pfdubois.com/numpy/
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 %requires_eq    python
23 BuildRequires:  python-devel >= 1.5
24
25 %description
26 NumPy is a collection of extension modules to provide high-performance
27 multidimensional numeric arrays to the Python programming language.
28
29 %description -l pl
30 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
31 wielowymiarowych.
32
33 %package devel
34 Summary:        C header files for numerical modules
35 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
36 Group:          Development/Languages/Python
37 Group(de):      Entwicklung/Sprachen/Python
38 Group(pl):      Programowanie/Jêzyki/Python
39 %requires_eq    python
40 Requires:       %{name} = %{version}
41
42 %description devel
43 C header files for numerical modules.
44
45 %description devel -l pl
46 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
47
48 %package FFT
49 Summary:        Interface to the FFTPACK FORTRAN library
50 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
51 Group:          Development/Languages/Python
52 Group(de):      Entwicklung/Sprachen/Python
53 Group(pl):      Programowanie/Jêzyki/Python
54 %requires_eq    python
55 Requires:       %{name} = %{version}
56
57 %description FFT
58 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
59 library, which is a powerful standard library for doing fast Fourier
60 transforms of real and complex data sets.
61
62 %description FFT -l pl
63 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
64 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
65 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
66 Fouriera na liczba rzeczywistych i zespolonych.
67
68 %package kinds
69 Summary:        PEP 0242
70 Group:          Development/Languages/Python
71 Group(de):      Entwicklung/Sprachen/Python
72 Group(pl):      Programowanie/Jêzyki/Python
73 %requires_eq    python
74 Requires:       %{name} = %{version}
75 Requires:       %{name}-kinds = %{version}
76
77 %description kinds
78 PEP 0242
79
80 %description kinds -l pl
81
82
83 %package MA
84 Summary:        MA - a facility for dealing with masked arrays
85 Summary(pl):    Modu³ do obs³ugi macierzy niepe³nych
86 Group:          Development/Languages/Python
87 Group(de):      Entwicklung/Sprachen/Python
88 Group(pl):      Programowanie/Jêzyki/Python
89 %requires_eq    python
90 Requires:       %{name} = %{version}
91
92 %description MA
93 Masked arrays are arrays that may have missing or invalid entries. Module
94 MA provides a work-alike replacement for Numeric that supports data arrays
95 with masks.
96
97 %description MA -l pl
98 Macierze niepe³ne s± to macierze, którym mo¿e brakowaæ lub mog± zawieraæ
99 niepoprawne warto¶ci. Modu³ MA zawiera odpowiednie narzêdzia do operowania
100 na tego typu macierzach.
101
102 %package Properties
103 Summary:        Property class implementation for Python
104 Summary(pl):    Implementacja klasy z w³a¶ciwo¶ciami dla jêzyka Python
105 Group:          Development/Languages/Python
106 Group(de):      Entwicklung/Sprachen/Python
107 Group(pl):      Programowanie/Jêzyki/Python
108 %requires_eq    python
109 Requires:       %{name} = %{version}
110
111 %description Properties
112 PropertiedClass is a mixin class that can be used to emulate properties in
113 a Python class. A property is an attribute whose read, write, or deleting
114 requires special handling. It is also possible to use this facility to
115 prevent the writing or deleting of a property.
116
117 %description Properties -l pl
118 PropertiedClass jest klas±, która mo¿e byæ u¿yta do emulacji w³a¶ciwo¶ci
119 w klasach jêzyka Python. W³a¶ciwo¶æ klasy jest atrybutem, którego czytanie,
120 przypisywanie mu warto¶ci, czy te¿ jego usuwanie powinno byæ traktowane
121 w sposób specjalny. Mechanizm ten mo¿e byæ te¿ u¿ywany w celu ustalenia
122 jakiego¶ atrybutu jako tylko do odczytu.
123
124 %package RNG
125 Summary:        Random Number Generator Object for NumPy
126 Summary:        Obiekt generatora liczb losowych dla modu³u NumPy
127 Group:          Development/Languages/Python
128 Group(de):      Entwicklung/Sprachen/Python
129 Group(pl):      Programowanie/Jêzyki/Python
130 %requires_eq    python
131 Requires:       %{name} = %{version}
132
133 %description RNG
134 RNG provides a random number object to Numerical Python.
135
136 %description RNG -l pl
137 Modu³ ten zawiera implementacjê obiektu generatora liczb losowych dla
138 jêzyka Python.
139
140 %prep
141 %setup -q -n %{mname}-%{version}
142
143 %build
144 python setup_all.py build
145
146 %install
147 python setup_all.py install --root=$RPM_BUILD_ROOT
148 %python_compile_opt $RPM_BUILD_ROOT%{python_sitepkgsdir}
149 %python_compile $RPM_BUILD_ROOT%{python_sitepkgsdir}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %dir %{python_sitepkgsdir}/%{mname}
157 %{python_sitepkgsdir}/%{mname}.pth
158 %attr(755,root,root) %{python_sitepkgsdir}/%{mname}/*.so
159 %{python_sitepkgsdir}/%{mname}/*.py[co]
160
161 %files devel
162 %defattr(644,root,root,755)
163 %{_includedir}/python%{python_ver}/%{mname}
164
165 %files FFT
166 %defattr(644,root,root,755)
167 %dir %{python_sitepkgsdir}/FFT
168 %attr(755,root,root) %{python_sitepkgsdir}/FFT/*.so
169 %{python_sitepkgsdir}/FFT/*.py[co]
170
171 %files kinds
172 %defattr(644,root,root,755)
173 %dir %{python_sitepkgsdir}/kinds
174 %attr(755,root,root) %{python_sitepkgsdir}/kinds/*.so
175 %{python_sitepkgsdir}/kinds/*.py[co]
176
177 %files MA
178 %defattr(644,root,root,755)
179 %dir %{python_sitepkgsdir}/MA
180 %{python_sitepkgsdir}/MA/*.py[co]
181
182 %files Properties
183 %defattr(644,root,root,755)
184 %{python_sitepkgsdir}/Properties.py[co]
185
186 %files RNG
187 %defattr(644,root,root,755)
188 %dir %{python_sitepkgsdir}/RNG
189 %attr(755,root,root) %{python_sitepkgsdir}/RNG/*.so
190 %{python_sitepkgsdir}/RNG/*.py[co]
This page took 0.04087 seconds and 4 git commands to generate.