]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- up to 1.0.1
[packages/python-numpy.git] / python-numpy.spec
1 #
2 # TODO:
3 #       - description for oldnumeric
4 #
5 %define         module  numpy
6
7 Summary:        Python numerical facilities
8 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
9 Name:           python-%{module}
10 Version:        1.0.1
11 Release:        0.1
12 Epoch:          1
13 License:        distributable
14 Group:          Libraries/Python
15 Source0:        http://dl.sourceforge.net/numpy/%{module}-%{version}.tar.gz
16 # Source0-md5:  13a29244cbe03e0d45e56d8d90ecb55d
17 URL:            http://sourceforge.net/projects/numpy/
18 BuildRequires:  python-devel >= 1:2.3
19 %pyrequires_eq  python-libs
20 # -- dropped some time ago
21 Obsoletes:      python-numpy-Properties
22 # -- dropped some time ago, should have been released as separate package, but wasn't
23 Obsoletes:      python-numpy-kinds
24 # -- dropped during Numeric->numpy transition
25 Obsoletes:      python-numpy-MA
26 Obsoletes:      python-numpy-RNG
27 Provides:       f2py
28 Provides:       numarray
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 NumPy is a collection of extension modules to provide high-performance
33 multidimensional numeric arrays to the Python programming language.
34
35 %description -l pl
36 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
37 wielowymiarowych.
38
39 %package devel
40 Summary:        C header files for numerical modules
41 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
42 Group:          Development/Languages/Python
43 %pyrequires_eq  python-devel
44 Requires:       %{name} = %{epoch}:%{version}-%{release}
45
46 %description devel
47 C header files for numerical modules.
48
49 %description devel -l pl
50 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
51
52 %package FFT
53 Summary:        Interface to the FFTPACK FORTRAN library
54 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
55 Group:          Libraries/Python
56 %pyrequires_eq  python-libs
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58
59 %description FFT
60 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
61 library, which is a powerful standard library for doing fast Fourier
62 transforms of real and complex data sets.
63
64 %description FFT -l pl
65 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
66 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
67 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
68 Fouriera na liczba rzeczywistych i zespolonych.
69
70 %package numarray
71 Summary:        Array manipulation and computations for python
72 Summary(pl):    Operacje i obliczenia na tablicach dla Pythona
73 Group:          Development/Languages/Python
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75
76 %description numarray
77 Numarray provides array manipulation and computational capabilities
78 similar to those found in IDL, Matlab, or Octave. Using numarray, it
79 is possible to write many efficient numerical data processing
80 applications directly in Python without using any C, C++ or Fortran
81 code (as well as doing such analysis interactively within Python or
82 PyRAF). For algorithms that are not well suited for efficient
83 computation using array facilities it is possible to write C functions
84 (and eventually Fortran) that can read and write numarray arrays that
85 can be called from Python.
86
87 Numarray is a re-implementation of an older Python array module called
88 Numeric. In general its interface is very similar. It is mostly
89 backward compatible and will be becoming more so in future releases.
90
91 %description numarray -l pl
92 Numarray zapewnia narzêdzia do operacji oraz obliczeñ na tablicach
93 podobne do tych, jakie zapewniaj± IDL, Matlab czy Octave. U¿ywaj±c
94 numarray mo¿liwe jest stworzenie bezpo¶rednio w Pythonie, nie u¿ywaj±c
95 wstawek C, C++ czy fortranowych, wielu wydajnych aplikacji do
96 przetwarzania danych numerycznych. Dla algorytmów, które nie pracuj±
97 wydajnie z tablicami, mo¿liwe jest napisanie funkcji C, które mog±
98 czytaæ i zapisywaæ tablice numarray, i które mog± byæ wywo³ywane z
99 poziomu Pythona.
100
101 Numarray jest ponown± implementacj± starszego modu³u Pythona -
102 Numeric. Interfejsy tych modu³ów s± do siebie bardzo podobne. Numarray
103 jest w wiêkszo¶ci przypadków kompatybilny wstecz, a sytuacja poprawi
104 siê w nowszych wersjach.
105
106 %package numarray-devel
107 Summary:        Header files for python-numarray
108 Summary(pl):    Pliki nag³ówkowe dla python-numarray
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
111 Requires:       %{name}-numarray = %{epoch}:%{version}-%{release}
112
113 %description numarray-devel
114 Header files for python-numarray.
115
116 %description numarray-devel -l pl
117 Pliki nag³ówkowe dla python-numarray.
118
119 %package oldnumeric
120 Summary:        Old numeric packages
121 Summary(pl):    Stare pakiety numeric
122 Group:          Libraries/Python
123
124 %description oldnumeric
125 Old numeric packages.
126
127 %description oldnumeric -l pl
128 Stare pakiety numeric.
129
130 %package -n f2py
131 Summary:        Fortran to Python interface generator
132 Summary(pl):    Generator interfejsów z Fortranu do Pythona
133 Group:          Libraries/Python
134 Requires:       python-%{module}
135
136 %description -n f2py
137 Fortran to Python interface generator.
138
139 %description -n f2py -l pl
140 Generator interfejsów z Fortranu do Pythona.
141
142 %prep
143 %setup -q -n %{module}-%{version}
144
145 %build
146 CC="%{__cc}"; export CC
147 CFLAGS="%{rpmcflags}"; export CFLAGS
148 python setup.py build
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 python setup.py install \
154         --root=$RPM_BUILD_ROOT
155
156 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
157 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
158 %py_postclean
159
160 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/{*.txt,COMPATIBILITY,scipy_compatibility,doc}
161 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*/{tests,docs}
162 # already in f2py package
163 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/f2py/f2py.1
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %defattr(644,root,root,755)
170 %dir %{py_sitedir}/%{module}
171 %{py_sitedir}/%{module}/*.py[co]
172 %{py_sitedir}/%{module}/tests
173 %dir %{py_sitedir}/%{module}/core
174 %{py_sitedir}/%{module}/core/*.py[co]
175 %attr(755,root,root) %{py_sitedir}/%{module}/core/*.so
176 %dir %{py_sitedir}/%{module}/distutils
177 %{py_sitedir}/%{module}/distutils/*.py[co]
178 %{py_sitedir}/%{module}/distutils/site.cfg
179 %dir %{py_sitedir}/%{module}/distutils/command
180 %{py_sitedir}/%{module}/distutils/command/*.py[co]
181 %dir %{py_sitedir}/%{module}/distutils/fcompiler
182 %{py_sitedir}/%{module}/distutils/fcompiler/*.py[co]
183 %dir %{py_sitedir}/%{module}/lib
184 %{py_sitedir}/%{module}/lib/*.py[co]
185 %attr(755,root,root) %{py_sitedir}/%{module}/lib/*.so
186 %dir %{py_sitedir}/%{module}/linalg
187 %{py_sitedir}/%{module}/linalg/*.py[co]
188 %attr(755,root,root) %{py_sitedir}/%{module}/linalg/*.so
189 %dir %{py_sitedir}/%{module}/random
190 %{py_sitedir}/%{module}/random/*.py[co]
191 %attr(755,root,root) %{py_sitedir}/%{module}/random/*.so
192 %dir %{py_sitedir}/%{module}/testing
193 %{py_sitedir}/%{module}/testing/*.py[co]
194
195 %files devel
196 %defattr(644,root,root,755)
197 %{py_sitedir}/%{module}/core/include
198 %{py_sitedir}/%{module}/random/*.h
199
200 %files FFT
201 %defattr(644,root,root,755)
202 %dir %{py_sitedir}/%{module}/fft
203 %attr(755,root,root) %{py_sitedir}/%{module}/fft/*.so
204 %{py_sitedir}/%{module}/fft/*.py[co]
205
206 %files numarray
207 %defattr(644,root,root,755)
208 %dir %{py_sitedir}/%{module}/numarray
209 %attr(755,root,root) %{py_sitedir}/%{module}/numarray/*.so
210 %{py_sitedir}/%{module}/numarray/*.py[co]
211
212 %files numarray-devel
213 %defattr(644,root,root,755)
214 %dir %{py_sitedir}/%{module}/numarray/numpy
215 %{py_sitedir}/%{module}/numarray/numpy/*
216
217 %files oldnumeric
218 %defattr(644,root,root,755)
219 %dir %{py_sitedir}/%{module}/oldnumeric
220 %{py_sitedir}/%{module}/oldnumeric/*
221
222 %files -n f2py
223 %defattr(644,root,root,755)
224 %attr(744,root,root) %{_bindir}/f2py
225 %dir %{py_sitedir}/%{module}/f2py
226 %{py_sitedir}/%{module}/f2py/*.py[co]
227 %{py_sitedir}/%{module}/f2py/src
228 %{py_sitedir}/%{module}/f2py/lib
This page took 0.046985 seconds and 3 git commands to generate.