]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- massive attack: added missing python-devel epoch do BR
[packages/python-numpy.git] / python-numpy.spec
1
2 %define         module  numpy
3 %define         mname   Numeric
4
5 Summary:        Python numerical facilities
6 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
7 Name:           python-%{module}
8 Version:        23.6
9 Release:        0.1
10 License:        distributable
11 Group:          Libraries/Python
12 Source0:        http://dl.sourceforge.net/numpy/%{mname}-%{version}.tar.gz
13 # Source0-md5:  89da82dd9dd7fc331f5752a68dc79dba
14 Patch0:         %{name}-lite.patch
15 URL:            http://www.pfdubois.com/numpy/
16 BuildRequires:  python-devel >= 1:2.3
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 NumPy is a collection of extension modules to provide high-performance
23 multidimensional numeric arrays to the Python programming language.
24
25 %description -l pl
26 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
27 wielowymiarowych.
28
29 %package devel
30 Summary:        C header files for numerical modules
31 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
32 Group:          Development/Languages/Python
33 %pyrequires_eq  python
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 C header files for numerical modules.
38
39 %description devel -l pl
40 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
41
42 %package FFT
43 Summary:        Interface to the FFTPACK FORTRAN library
44 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
45 Group:          Libraries/Python
46 %pyrequires_eq  python
47 Requires:       %{name} = %{version}-%{release}
48
49 %description FFT
50 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
51 library, which is a powerful standard library for doing fast Fourier
52 transforms of real and complex data sets.
53
54 %description FFT -l pl
55 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
56 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
57 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
58 Fouriera na liczba rzeczywistych i zespolonych.
59
60 # -- will be released as separate package
61 #%package kinds
62 #Summary:       Implementation of PEP 0242 - precision and range control of numeric computations
63 #Summary(pl):   Implementacja propozycji PEP 0242 - mo¿liwo¶æ kontrolowania precyzji i zakresu obliczeñ numerycznych
64 #Group:         Libraries/Python
65 #%pyrequires_eq python
66 #Requires:      %{name} = %{version}-%{release}
67 #
68 #%description kinds
69 #This is implementation of PEP 0242. PEP's abstract follows:
70 #
71 #This proposal gives the user optional control over the precision and
72 #range of numeric computations so that a computation can be written
73 #once and run anywhere with at least the desired precision and range.
74 #It is backward compatible with existing code.
75 #
76 #%description kinds -l pl
77 #Modu³ zawiera implementacjê propozycji PEP 0242. Oto jej streszczenie.
78 #
79 #Propozycja ta umo¿liwia u¿ytkownikowi, opcjonalnie, kontrolê nad
80 #precyzj± i zakresem obliczeñ numerycznych. Dziêki temu raz napisane
81 #obliczenia mog± byæ uruchamiane na dowolnej maszynie. Mechanizm jest
82 #kompatybilny wstecz z istniej±cymi programami.
83
84 %package MA
85 Summary:        MA - a facility for dealing with masked arrays
86 Summary(pl):    Modu³ do obs³ugi macierzy niepe³nych
87 Group:          Libraries/Python
88 %pyrequires_eq  python
89 Requires:       %{name} = %{version}-%{release}
90
91 %description MA
92 Masked arrays are arrays that may have missing or invalid entries.
93 Module MA provides a work-alike replacement for Numeric that supports
94 data arrays with masks.
95
96 %description MA -l pl
97 Macierze niepe³ne s± to macierze, którym mo¿e brakowaæ lub mog±
98 zawieraæ niepoprawne warto¶ci. Modu³ MA zawiera odpowiednie narzêdzia
99 do operowania na tego typu macierzach.
100
101 # -- removed(?)
102 #%package Properties
103 #Summary:       Property class implementation for Python
104 #Summary(pl):   Implementacja klasy z w³a¶ciwo¶ciami dla jêzyka Python
105 #Group:         Libraries/Python
106 #%pyrequires_eq python
107 #Requires:      %{name} = %{version}-%{release}
108 #
109 #%description Properties
110 #PropertiedClass is a mixin class that can be used to emulate
111 #properties in a Python class. A property is an attribute whose read,
112 #write, or deleting requires special handling. It is also possible to
113 #use this facility to prevent the writing or deleting of a property.
114 #
115 #%description Properties -l pl
116 #PropertiedClass jest klas±, która mo¿e byæ u¿yta do emulacji
117 #w³a¶ciwo¶ci w klasach jêzyka Python. W³a¶ciwo¶æ klasy jest atrybutem,
118 #którego czytanie, przypisywanie mu warto¶ci, czy te¿ jego usuwanie
119 #powinno byæ traktowane w sposób specjalny. Mechanizm ten mo¿e byæ te¿
120 #u¿ywany w celu ustalenia jakiego¶ atrybutu jako tylko do odczytu.
121
122 %package RNG
123 Summary:        Random Number Generator Object for NumPy
124 Summary(pl):    Obiekt generatora liczb losowych dla modu³u NumPy
125 Group:          Libraries/Python
126 %pyrequires_eq  python
127 Requires:       %{name} = %{version}-%{release}
128
129 %description RNG
130 RNG provides a random number object to Numerical Python.
131
132 %description RNG -l pl
133 Modu³ ten zawiera implementacjê obiektu generatora liczb losowych dla
134 jêzyka Python.
135
136 %prep
137 %setup -q -n %{mname}-%{version}
138 %patch0 -p1
139
140 %build
141 CC="%{__cc}"; export CC
142 CFLAGS="%{rpmcflags}"; export CFLAGS
143 python setup.py build
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 python setup.py install \
149         --root=$RPM_BUILD_ROOT
150
151 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
152 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %files
158 %defattr(644,root,root,755)
159 %dir %{py_sitedir}/%{mname}
160 %{py_sitedir}/%{mname}.pth
161 %attr(755,root,root) %{py_sitedir}/%{mname}/*.so
162 %{py_sitedir}/%{mname}/*.py[co]
163
164 %files devel
165 %defattr(644,root,root,755)
166 %{py_incdir}/%{mname}
167
168 %files FFT
169 %defattr(644,root,root,755)
170 %dir %{py_sitedir}/%{mname}/FFT
171 %attr(755,root,root) %{py_sitedir}/%{mname}/FFT/*.so
172 %{py_sitedir}/%{mname}/FFT/*.py[co]
173
174 #%files kinds
175 #%defattr(644,root,root,755)
176 #%dir %{py_sitedir}/%{mname}/kinds
177 #%attr(755,root,root) %{py_sitedir}/%{mname}/kinds/*.so
178 #%{py_sitedir}/%{mname}/kinds/*.py[co]
179
180 %files MA
181 %defattr(644,root,root,755)
182 %dir %{py_sitedir}/%{mname}/MA
183 %{py_sitedir}/%{mname}/MA/*.py[co]
184
185 #%files Properties
186 #%defattr(644,root,root,755)
187 #%dir %{py_sitedir}/%{mname}/PropertiedClasses
188 #%{py_sitedir}/%{mname}/PropertiedClasses/*.py[co]
189
190 %files RNG
191 %defattr(644,root,root,755)
192 %dir %{py_sitedir}/%{mname}/RNG
193 %attr(755,root,root) %{py_sitedir}/%{mname}/RNG/*.so
194 %{py_sitedir}/%{mname}/RNG/*.py[co]
This page took 0.0379 seconds and 3 git commands to generate.