]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- ver. 20.2.0
[packages/python-numpy.git] / python-numpy.spec
1
2 %define module numpy
3 %define mname Numeric
4
5 %define python_ver      %(echo `python -c "import sys; print (sys.version[:3])"`)
6 %define python_sitepkgsdir      %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
7 %define python_compile_opt python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1])"
8 %define python_compile python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1])"
9
10 Summary:        Python numerical facilities 
11 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
12 Name:           python-%{module}
13 Version:        20.2.0
14 Release:        1
15 License:        Distributable
16 Group:          Development/Languages/Python
17 Group(de):      Entwicklung/Sprachen/Python
18 Group(pl):      Programowanie/Jêzyki/Python
19 Source0:        http://prdownloads.sourceforge.net/numpy/%{mname}-%{version}.tar.gz
20 URL:            http://www.pfdubois.com/numpy/
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 %requires_eq    python
23 BuildRequires:  python-devel >= 1.5
24
25 %description
26 NumPy is a collection of extension modules to provide high-performance
27 multidimensional numeric arrays to the Python programming language.
28
29 %description -l pl
30 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
31 wielowymiarowych.
32
33 %package devel
34 Summary:        C header files for numerical modules
35 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
36 Group:          Development/Languages/Python
37 Group(de):      Entwicklung/Sprachen/Python
38 Group(pl):      Programowanie/Jêzyki/Python
39 %requires_eq    python
40 Requires:       %{name} = %{version}
41
42 %description devel
43 C header files for numerical modules.
44
45 %description devel -l pl
46 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
47
48 %package FFT
49 Summary:        Interface to the FFTPACK FORTRAN library
50 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
51 Group:          Development/Languages/Python
52 Group(de):      Entwicklung/Sprachen/Python
53 Group(pl):      Programowanie/Jêzyki/Python
54 %requires_eq    python
55 Requires:       %{name} = %{version}
56
57 %description FFT
58 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
59 library, which is a powerful standard library for doing fast Fourier
60 transforms of real and complex data sets.
61
62 %description FFT -l pl
63 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
64 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
65 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
66 Fouriera na liczba rzeczywistych i zespolonych.
67
68 %package kinds
69 Summary:        Implementation of PEP 0242 - precision and range control of numeric computations
70 Summary(pl):    Implementacja propozycji PEP 0242 - mo¿liwo¶æ kontrolowania precyzji i zakresu obliczeñ numerycznych
71 Group:          Development/Languages/Python
72 Group(de):      Entwicklung/Sprachen/Python
73 Group(pl):      Programowanie/Jêzyki/Python
74 %requires_eq    python
75 Requires:       %{name} = %{version}
76 Requires:       %{name}-kinds = %{version}
77
78 %description kinds
79 This is implementation of PEP 0242. PEP's abstract follows:
80
81 This proposal gives the user optional control over the precision and
82 range of numeric computations so that a computation can be written
83 once and run anywhere with at least the desired precision and range.
84 It is backward compatible with existing code.
85
86 %description kinds -l pl
87 Modu³ zawiera implementacjê propozycji PEP 0242. Oto jej streszczenie.
88
89 Propozycja ta umo¿liwia u¿ytkownikowi, opcjonalnie, kontrolê nad
90 precyzj± i zakresem obliczeñ numerycznych. Dziêki temu raz napisane
91 obliczenia mog± byæ uruchamiane na dowolnej maszynie. Mechanizm jest
92 kompatybilny wstecz z istniej±cymi programami.
93
94 %package MA
95 Summary:        MA - a facility for dealing with masked arrays
96 Summary(pl):    Modu³ do obs³ugi macierzy niepe³nych
97 Group:          Development/Languages/Python
98 Group(de):      Entwicklung/Sprachen/Python
99 Group(pl):      Programowanie/Jêzyki/Python
100 %requires_eq    python
101 Requires:       %{name} = %{version}
102
103 %description MA
104 Masked arrays are arrays that may have missing or invalid entries.
105 Module MA provides a work-alike replacement for Numeric that supports
106 data arrays with masks.
107
108 %description MA -l pl
109 Macierze niepe³ne s± to macierze, którym mo¿e brakowaæ lub mog±
110 zawieraæ niepoprawne warto¶ci. Modu³ MA zawiera odpowiednie narzêdzia
111 do operowania na tego typu macierzach.
112
113 %package Properties
114 Summary:        Property class implementation for Python
115 Summary(pl):    Implementacja klasy z w³a¶ciwo¶ciami dla jêzyka Python
116 Group:          Development/Languages/Python
117 Group(de):      Entwicklung/Sprachen/Python
118 Group(pl):      Programowanie/Jêzyki/Python
119 %requires_eq    python
120 Requires:       %{name} = %{version}
121
122 %description Properties
123 PropertiedClass is a mixin class that can be used to emulate
124 properties in a Python class. A property is an attribute whose read,
125 write, or deleting requires special handling. It is also possible to
126 use this facility to prevent the writing or deleting of a property.
127
128 %description Properties -l pl
129 PropertiedClass jest klas±, która mo¿e byæ u¿yta do emulacji
130 w³a¶ciwo¶ci w klasach jêzyka Python. W³a¶ciwo¶æ klasy jest atrybutem,
131 którego czytanie, przypisywanie mu warto¶ci, czy te¿ jego usuwanie
132 powinno byæ traktowane w sposób specjalny. Mechanizm ten mo¿e byæ te¿
133 u¿ywany w celu ustalenia jakiego¶ atrybutu jako tylko do odczytu.
134
135 %package RNG
136 Summary:        Random Number Generator Object for NumPy
137 Summary:        Obiekt generatora liczb losowych dla modu³u NumPy
138 Group:          Development/Languages/Python
139 Group(de):      Entwicklung/Sprachen/Python
140 Group(pl):      Programowanie/Jêzyki/Python
141 %requires_eq    python
142 Requires:       %{name} = %{version}
143
144 %description RNG
145 RNG provides a random number object to Numerical Python.
146
147 %description RNG -l pl
148 Modu³ ten zawiera implementacjê obiektu generatora liczb losowych dla
149 jêzyka Python.
150
151 %prep
152 %setup -q -n %{mname}-%{version}
153
154 %build
155 CFLAGS="%{rpmcflags}"
156 export CFLAGS
157 python setup_all.py build
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 python setup_all.py install --root=$RPM_BUILD_ROOT
162 %python_compile_opt $RPM_BUILD_ROOT%{python_sitepkgsdir}
163 %python_compile $RPM_BUILD_ROOT%{python_sitepkgsdir}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %defattr(644,root,root,755)
170 %dir %{python_sitepkgsdir}/%{mname}
171 %{python_sitepkgsdir}/%{mname}.pth
172 %attr(755,root,root) %{python_sitepkgsdir}/%{mname}/*.so
173 %{python_sitepkgsdir}/%{mname}/*.py[co]
174
175 %files devel
176 %defattr(644,root,root,755)
177 %{_includedir}/python%{python_ver}/%{mname}
178
179 %files FFT
180 %defattr(644,root,root,755)
181 %dir %{python_sitepkgsdir}/FFT
182 %attr(755,root,root) %{python_sitepkgsdir}/FFT/*.so
183 %{python_sitepkgsdir}/FFT/*.py[co]
184
185 %files kinds
186 %defattr(644,root,root,755)
187 %dir %{python_sitepkgsdir}/kinds
188 %attr(755,root,root) %{python_sitepkgsdir}/kinds/*.so
189 %{python_sitepkgsdir}/kinds/*.py[co]
190
191 %files MA
192 %defattr(644,root,root,755)
193 %dir %{python_sitepkgsdir}/MA
194 %{python_sitepkgsdir}/MA/*.py[co]
195
196 %files Properties
197 %defattr(644,root,root,755)
198 %dir %{python_sitepkgsdir}/PropertiedClasses
199 %{python_sitepkgsdir}/PropertiedClasses/*.py[co]
200
201 %files RNG
202 %defattr(644,root,root,755)
203 %dir %{python_sitepkgsdir}/RNG
204 %attr(755,root,root) %{python_sitepkgsdir}/RNG/*.so
205 %{python_sitepkgsdir}/RNG/*.py[co]
This page took 0.444136 seconds and 3 git commands to generate.