]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- removed obsolete lite patch
[packages/python-numpy.git] / python-numpy.spec
1 %define         module  numpy
2 %define         mname   Numeric
3
4 Summary:        Python numerical facilities
5 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
6 Name:           python-%{module}
7 Version:        24.2
8 Release:        1
9 License:        distributable
10 Group:          Libraries/Python
11 Source0:        http://dl.sourceforge.net/numpy/%{mname}-%{version}.tar.gz
12 # Source0-md5:  2ae672656e06716a149acb048cca3093
13 URL:            http://sourceforge.net/projects/numpy/
14 BuildRequires:  python-devel >= 1:2.3
15 %pyrequires_eq  python-libs
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 NumPy is a collection of extension modules to provide high-performance
20 multidimensional numeric arrays to the Python programming language.
21
22 %description -l pl
23 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
24 wielowymiarowych.
25
26 %package devel
27 Summary:        C header files for numerical modules
28 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
29 Group:          Development/Languages/Python
30 %pyrequires_eq  python-devel
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 C header files for numerical modules.
35
36 %description devel -l pl
37 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
38
39 %package FFT
40 Summary:        Interface to the FFTPACK FORTRAN library
41 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
42 Group:          Libraries/Python
43 %pyrequires_eq  python-libs
44 Requires:       %{name} = %{version}-%{release}
45
46 %description FFT
47 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
48 library, which is a powerful standard library for doing fast Fourier
49 transforms of real and complex data sets.
50
51 %description FFT -l pl
52 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
53 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
54 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
55 Fouriera na liczba rzeczywistych i zespolonych.
56
57 # -- will be released as separate package
58 #%package kinds
59 #Summary:       Implementation of PEP 0242 - precision and range control of numeric computations
60 #Summary(pl):   Implementacja propozycji PEP 0242 - mo¿liwo¶æ kontrolowania precyzji i zakresu obliczeñ numerycznych
61 #Group:         Libraries/Python
62 #%pyrequires_eq python-libs
63 #Requires:      %{name} = %{version}-%{release}
64 #
65 #%description kinds
66 #This is implementation of PEP 0242. PEP's abstract follows:
67 #
68 #This proposal gives the user optional control over the precision and
69 #range of numeric computations so that a computation can be written
70 #once and run anywhere with at least the desired precision and range.
71 #It is backward compatible with existing code.
72 #
73 #%description kinds -l pl
74 #Modu³ zawiera implementacjê propozycji PEP 0242. Oto jej streszczenie.
75 #
76 #Propozycja ta umo¿liwia u¿ytkownikowi, opcjonalnie, kontrolê nad
77 #precyzj± i zakresem obliczeñ numerycznych. Dziêki temu raz napisane
78 #obliczenia mog± byæ uruchamiane na dowolnej maszynie. Mechanizm jest
79 #kompatybilny wstecz z istniej±cymi programami.
80
81 %package MA
82 Summary:        MA - a facility for dealing with masked arrays
83 Summary(pl):    Modu³ do obs³ugi macierzy niepe³nych
84 Group:          Libraries/Python
85 %pyrequires_eq  python-libs
86 Requires:       %{name} = %{version}-%{release}
87
88 %description MA
89 Masked arrays are arrays that may have missing or invalid entries.
90 Module MA provides a work-alike replacement for Numeric that supports
91 data arrays with masks.
92
93 %description MA -l pl
94 Macierze niepe³ne s± to macierze, którym mo¿e brakowaæ lub mog±
95 zawieraæ niepoprawne warto¶ci. Modu³ MA zawiera odpowiednie narzêdzia
96 do operowania na tego typu macierzach.
97
98 # -- removed(?)
99 #%package Properties
100 #Summary:       Property class implementation for Python
101 #Summary(pl):   Implementacja klasy z w³a¶ciwo¶ciami dla jêzyka Python
102 #Group:         Libraries/Python
103 #%pyrequires_eq python-libs
104 #Requires:      %{name} = %{version}-%{release}
105 #
106 #%description Properties
107 #PropertiedClass is a mixin class that can be used to emulate
108 #properties in a Python class. A property is an attribute whose read,
109 #write, or deleting requires special handling. It is also possible to
110 #use this facility to prevent the writing or deleting of a property.
111 #
112 #%description Properties -l pl
113 #PropertiedClass jest klas±, która mo¿e byæ u¿yta do emulacji
114 #w³a¶ciwo¶ci w klasach jêzyka Python. W³a¶ciwo¶æ klasy jest atrybutem,
115 #którego czytanie, przypisywanie mu warto¶ci, czy te¿ jego usuwanie
116 #powinno byæ traktowane w sposób specjalny. Mechanizm ten mo¿e byæ te¿
117 #u¿ywany w celu ustalenia jakiego¶ atrybutu jako tylko do odczytu.
118
119 %package RNG
120 Summary:        Random Number Generator Object for NumPy
121 Summary(pl):    Obiekt generatora liczb losowych dla modu³u NumPy
122 Group:          Libraries/Python
123 %pyrequires_eq  python-libs
124 Requires:       %{name} = %{version}-%{release}
125
126 %description RNG
127 RNG provides a random number object to Numerical Python.
128
129 %description RNG -l pl
130 Modu³ ten zawiera implementacjê obiektu generatora liczb losowych dla
131 jêzyka Python.
132
133 %prep
134 %setup -q -n %{mname}-%{version}
135
136 %build
137 CC="%{__cc}"; export CC
138 CFLAGS="%{rpmcflags}"; export CFLAGS
139 python setup.py build
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 python setup.py install \
145         --root=$RPM_BUILD_ROOT
146
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
148 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %dir %{py_sitedir}/%{mname}
156 %{py_sitedir}/%{mname}.pth
157 %attr(755,root,root) %{py_sitedir}/%{mname}/*.so
158 %{py_sitedir}/%{mname}/Numeric_headers/__init__.*
159 %{py_sitedir}/%{mname}/*.py[co]
160 %{py_sitedir}/%{mname}/*.py
161
162 %files devel
163 %defattr(644,root,root,755)
164 %{py_incdir}/%{mname}
165
166 %files FFT
167 %defattr(644,root,root,755)
168 %dir %{py_sitedir}/%{mname}/FFT
169 %attr(755,root,root) %{py_sitedir}/%{mname}/FFT/*.so
170 %{py_sitedir}/%{mname}/FFT/*.py[co]
171 %{py_sitedir}/%{mname}/FFT/*.py
172
173 #%files kinds
174 #%defattr(644,root,root,755)
175 #%dir %{py_sitedir}/%{mname}/kinds
176 #%attr(755,root,root) %{py_sitedir}/%{mname}/kinds/*.so
177 #%{py_sitedir}/%{mname}/kinds/*.py[co]
178
179 %files MA
180 %defattr(644,root,root,755)
181 %dir %{py_sitedir}/%{mname}/MA
182 %{py_sitedir}/%{mname}/MA/*.py[co]
183 %{py_sitedir}/%{mname}/MA/*.py
184
185 #%files Properties
186 #%defattr(644,root,root,755)
187 #%dir %{py_sitedir}/%{mname}/PropertiedClasses
188 #%{py_sitedir}/%{mname}/PropertiedClasses/*.py[co]
189
190 %files RNG
191 %defattr(644,root,root,755)
192 %dir %{py_sitedir}/%{mname}/RNG
193 %attr(755,root,root) %{py_sitedir}/%{mname}/RNG/*.so
194 %{py_sitedir}/%{mname}/RNG/*.py[co]
195 %{py_sitedir}/%{mname}/RNG/*.py
This page took 0.086304 seconds and 3 git commands to generate.