]> git.pld-linux.org Git - packages/python-nss.git/blob - python-nss.spec
rebuild with python 3.10
[packages/python-nss.git] / python-nss.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Python 2 bindings for NSS and NSPR
7 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek NSS i NSPR
8 Name:           python-nss
9 Version:        1.0.1
10 Release:        7
11 License:        MPL v2.0 or GPL v2+ or LGPL v2+
12 Group:          Development/Languages/Python
13 Source0:        http://ftp.mozilla.org/pub/security/python-nss/releases/PYNSS_RELEASE_1_0_1/src/%{name}-%{version}.tar.bz2
14 # Source0-md5:  8c7fc2b76122d9d950138c61c876e2ee
15 Patch0:         type-conflicts.patch
16 URL:            http://www.mozilla.org/projects/security/pki/nss/
17 BuildRequires:  nspr-devel >= 4
18 BuildRequires:  nss-devel >= 3
19 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
20 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.714
23 Requires:       python-libs >= 1:2.7
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Python 2 bindings for Network Security Services (NSS) and Netscape
28 Portable Runtime (NSPR).
29
30 %description -l pl.UTF-8
31 Wiązania Pythona 2 do bibliotek NSS (Network Security Services) oraz
32 NSPR (Netscape Portable Runtime).
33
34 %package -n python3-nss
35 Summary:        Python 3 bindings for NSS and NSPR
36 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek NSS i NSPR
37 Group:          Development/Languages/Python
38 Requires:       python3-libs >= 1:3.2
39
40 %description -n python3-nss
41 Python 3 bindings for Network Security Services (NSS) and Netscape
42 Portable Runtime (NSPR).
43
44 %description -n python3-nss -l pl.UTF-8
45 Wiązania Pythona 3 do bibliotek NSS (Network Security Services) oraz
46 NSPR (Netscape Portable Runtime).
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 %build
53 %if %{with python2}
54 %py_build
55 %endif
56
57 %if %{with python3}
58 %py3_build
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %if %{with python2}
65 %py_install
66
67 %py_postclean
68 %endif
69
70 %if %{with python3}
71 %py3_install
72 %endif
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %if %{with python2}
78 %files
79 %defattr(644,root,root,755)
80 %doc README doc/ChangeLog
81 %dir %{py_sitedir}/nss
82 %{py_sitedir}/nss/__init__.py[co]
83 %attr(755,root,root) %{py_sitedir}/nss/error.so
84 %attr(755,root,root) %{py_sitedir}/nss/io.so
85 %attr(755,root,root) %{py_sitedir}/nss/nss.so
86 %attr(755,root,root) %{py_sitedir}/nss/ssl.so
87 %{py_sitedir}/python_nss-%{version}-py*.egg-info
88 %endif
89
90 %if %{with python3}
91 %files -n python3-nss
92 %defattr(644,root,root,755)
93 %doc README doc/ChangeLog
94 %dir %{py3_sitedir}/nss
95 %{py3_sitedir}/nss/__init__.py
96 %{py3_sitedir}/nss/__pycache__
97 %attr(755,root,root) %{py3_sitedir}/nss/error.cpython-*.so
98 %attr(755,root,root) %{py3_sitedir}/nss/io.cpython-*.so
99 %attr(755,root,root) %{py3_sitedir}/nss/nss.cpython-*.so
100 %attr(755,root,root) %{py3_sitedir}/nss/ssl.cpython-*.so
101 %{py3_sitedir}/python_nss-%{version}-py*.egg-info
102 %endif
This page took 0.064567 seconds and 3 git commands to generate.