]> git.pld-linux.org Git - packages/python-novaclient.git/blob - python-novaclient.spec
- release 4 (by relup.sh)
[packages/python-novaclient.git] / python-novaclient.spec
1 #
2 # Conditional build:
3 %bcond_with     doc     # do build doc (missing deps)
4 %bcond_with     tests   # do perform "make test" (missing deps)
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 Summary:        Client library for OpenStack Compute API
9 Name:           python-novaclient
10 Version:        9.1.0
11 Release:        4
12 License:        Apache
13 Group:          Libraries/Python
14 Source0:        https://files.pythonhosted.org/packages/source/p/python-novaclient/%{name}-%{version}.tar.gz
15 # Source0-md5:  4be037d19ec5ab7967d51a445a0c29e3
16 URL:            https://pypi.python.org/pypi/python-novaclient
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-pbr >= 2.0.0
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-pbr >= 2.0.0
25 BuildRequires:  python3-setuptools
26 %endif
27 Requires:       python-babel >= 2.3.4
28 Requires:       python-iso8601 >= 0.1.11
29 Requires:       python-keystoneauth1 >= 3.0.1
30 Requires:       python-oslo.i18n >= 2.1.0
31 Requires:       python-oslo.serialization >= 1.10.0
32 Requires:       python-oslo.utils >= 3.20.0
33 Requires:       python-pbr >= 2.0.0
34 Requires:       python-prettytable >= 0.7.1
35 Requires:       python-simplejson >= 2.2.0
36 Requires:       python-six >= 1.9.0
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This is a client for the OpenStack Compute API. It provides a Python
42 API (the novaclient module) which implements 100% of the OpenStack
43 Compute API.
44
45 %package -n python3-novaclient
46 Summary:        Client library for OpenStack Compute API
47 Group:          Libraries/Python
48 Requires:       python3-modules
49
50 %description -n python3-novaclient
51 This is a client for the OpenStack Compute API. It provides a Python
52 API (the novaclient module) which implements 100% of the OpenStack
53 Compute API.
54
55 %package -n novaclient
56 Summary:        Client library OpenStack Compute API
57 Group:          Applications
58 %if %{with python3}
59 Requires:       python3-novaclient = %{version}-%{release}
60 %else
61 Requires:       %{name} = %{version}-%{release}
62 %endif
63
64 %description -n novaclient
65 This is a client for the OpenStack Compute API. It provides a
66 command-line script (nova) which implements 100% of the OpenStack
67 Compute API.
68
69 %package apidocs
70 Summary:        API documentation for Python novaclient module
71 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona novaclient
72 Group:          Documentation
73
74 %description apidocs
75 API documentation for Pythona novaclient module.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API modułu Pythona novaclient.
79
80 %prep
81 %setup -q
82
83 %build
84 %if %{with python2}
85 %py_build %{?with_tests:test}
86 %endif
87
88 %if %{with python3}
89 %py3_build %{?with_tests:test}
90 %endif
91
92 %if %{with doc}
93 cd docs
94 %{__make} -j1 html
95 rm -rf _build/html/_sources
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %py_install
103
104 %py_postclean
105 %endif
106
107 %if %{with python3}
108 %py3_install
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with python2}
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog README.rst
118 %{py_sitescriptdir}/novaclient
119 %{py_sitescriptdir}/python_novaclient-%{version}-py*.egg-info
120 %endif
121
122 %if %{with python3}
123 %files -n python3-novaclient
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog README.rst
126 %{py3_sitescriptdir}/novaclient
127 %{py3_sitescriptdir}/python_novaclient-%{version}-py*.egg-info
128 %endif
129
130 %files -n novaclient
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog README.rst
133 %attr(755,root,root) %{_bindir}/nova
134
135 %if %{with doc}
136 %files apidocs
137 %defattr(644,root,root,755)
138 %doc doc/_build/html/*
139 %endif
This page took 0.089837 seconds and 3 git commands to generate.