]> git.pld-linux.org Git - packages/python-nosexcover.git/blob - python-nosexcover.spec
cfc31d35dbde15943cbc5a18567bd59e8a9b9353
[packages/python-nosexcover.git] / python-nosexcover.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        nose.plugins.cover extension to add Cobertura-style XML reports
8 Summary(pl.UTF-8):      Rozszerzenie nose.plugins.cover dodające raporty XML w stylu Cobertury
9 Name:           python-nosexcover
10 Version:        1.0.11
11 Release:        5
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/nosexcover/
15 Source0:        https://files.pythonhosted.org/packages/source/n/nosexcover/nosexcover-%{version}.tar.gz
16 # Source0-md5:  f32ef4824b4484343e9766b2c376365d
17 URL:            https://github.com/cmheisel/nose-xcover
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.6
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-coverage >= 3.4
23 BuildRequires:  python-nose
24 %endif
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-modules >= 1:3.2
28 BuildRequires:  python3-setuptools
29 %if %{with tests}
30 BuildRequires:  python3-coverage >= 3.4
31 BuildRequires:  python3-nose
32 %endif
33 %endif
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 Requires:       python-modules >= 1:2.6
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A companion to the built-in nose.plugins.cover, this plugin will write
42 out an XML coverage report to a file named coverage.xml.
43
44 %description -l pl.UTF-8
45 Dodatek do wbudowanego nose.plugins.cover - wtyczka zapisująca raport
46 pokrycia XML do pliku o nazwie coverage.xml.
47
48 %package -n python3-nosexcover
49 Summary:        nose.plugins.cover extension to add Cobertura-style XML reports
50 Summary(pl.UTF-8):      Rozszerzenie nose.plugins.cover dodające raporty XML w stylu Cobertury
51 Group:          Libraries/Python
52 Requires:       python3-modules >= 1:3.2
53
54 %description -n python3-nosexcover
55 A companion to the built-in nose.plugins.cover, this plugin will write
56 out an XML coverage report to a file named coverage.xml.
57
58 %description -n python3-nosexcover -l pl.UTF-8
59 Dodatek do wbudowanego nose.plugins.cover - wtyczka zapisująca raport
60 pokrycia XML do pliku o nazwie coverage.xml.
61
62 %prep
63 %setup -q -n nosexcover-%{version}
64
65 %build
66 %if %{with python2}
67 %py_build
68
69 %{?with_tests:nosetests-%{py_ver} nosexcover}
70 %endif
71
72 %if %{with python3}
73 %py3_build
74
75 %{?with_tests:nosetests-%{py3_ver} nosexcover}
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %py_install
83
84 %py_postclean
85 %endif
86
87 %if %{with python3}
88 %py3_install
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %if %{with python2}
95 %files
96 %defattr(644,root,root,755)
97 %doc README.rst
98 %{py_sitescriptdir}/nosexcover
99 %{py_sitescriptdir}/nosexcover-%{version}-py*.egg-info
100 %endif
101
102 %if %{with python3}
103 %files -n python3-nosexcover
104 %defattr(644,root,root,755)
105 %doc README.rst
106 %{py3_sitescriptdir}/nosexcover
107 %{py3_sitescriptdir}/nosexcover-%{version}-py*.egg-info
108 %endif
This page took 0.040913 seconds and 2 git commands to generate.