]> git.pld-linux.org Git - packages/python-nose_exclude.git/blob - python-nose_exclude.spec
976d9a01784307f0738f47aeea2284697f077210
[packages/python-nose_exclude.git] / python-nose_exclude.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Exclude specific directories from nosetests runs
8 Summary(pl.UTF-8):      Wykluczanie określonych katalogów z zakresu nosetests
9 Name:           python-nose_exclude
10 Version:        0.5.0
11 Release:        3
12 License:        LGPL
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/nose-exclude/
15 Source0:        https://files.pythonhosted.org/packages/source/n/nose-exclude/nose-exclude-%{version}.tar.gz
16 # Source0-md5:  072f72e782f28a9c42356976f8ec22d9
17 URL:            https://pypi.org/project/nose-exclude/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.5
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-nose
23 %endif
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.3
27 BuildRequires:  python3-setuptools
28 %if %{with tests}
29 BuildRequires:  python3-nose
30 %endif
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python-modules >= 1:2.5
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 nose_exclude is a Nose plugin that allows you to easily specify
40 directories to be excluded from testing.
41
42 %description -l pl.UTF-8
43 nose_exclude to wtyczka Nose pozwalająca łatwo określać katalogi
44 do wykluczenia z testowania.
45
46 %package -n python3-nose_exclude
47 Summary:        Exclude specific directories from nosetests runs
48 Summary(pl.UTF-8):      Wykluczanie określonych katalogów z zakresu nosetests
49 Group:          Libraries/Python
50 Requires:       python3-modules >= 1:3.3
51
52 %description -n python3-nose_exclude
53 nose_exclude is a Nose plugin that allows you to easily specify
54 directories to be excluded from testing.
55
56 %description -n python3-nose_exclude -l pl.UTF-8
57 nose_exclude to wtyczka Nose pozwalająca łatwo określać katalogi
58 do wykluczenia z testowania.
59
60 %prep
61 %setup -q -n nose-exclude-%{version}
62
63 %build
64 %if %{with python2}
65 %py_build %{?with_tests:test}
66 %endif
67
68 %if %{with python3}
69 %py3_build %{?with_tests:test}
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with python2}
76 %py_install
77
78 %py_postclean
79 %endif
80
81 %if %{with python3}
82 %py3_install
83 %endif
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %files
90 %defattr(644,root,root,755)
91 %doc README.rst
92 %{py_sitescriptdir}/nose_exclude.py[co]
93 %{py_sitescriptdir}/nose_exclude-%{version}-py*.egg-info
94 %endif
95
96 %if %{with python3}
97 %files -n python3-nose_exclude
98 %defattr(644,root,root,755)
99 %doc README.rst
100 %{py3_sitescriptdir}/nose_exclude.py
101 %{py3_sitescriptdir}/__pycache__/nose_exclude.cpython-*.py[co]
102 %{py3_sitescriptdir}/nose_exclude-%{version}-py*.egg-info
103 %endif
This page took 0.126216 seconds and 2 git commands to generate.