]> git.pld-linux.org Git - packages/python-nose.git/blob - python-nose.spec
caaa7ce08d0bac57fb88f7416930f7fde524328b
[packages/python-nose.git] / python-nose.spec
1 %define         module  nose
2 Summary:        A unittest extension with automatic discovery, simplified authoring, and output capture
3 Summary(pl.UTF-8):      Rozszerzenie testów jednostkowych z automatycznym wykrywaniem, prostym tworzeniem i przechwytywaniem wyjścia
4 Name:           python-%{module}
5 Version:        1.0.0
6 Release:        4
7 License:        LGPL
8 Group:          Libraries/Python
9 Source0:        http://pypi.python.org/packages/source/n/%{module}/%{module}-%{version}.tar.gz
10 # Source0-md5:  47a4784c817afa6ef11a505b574584ed
11 URL:            http://pypi.python.org/pypi/nose
12 BuildRequires:  python-devel
13 BuildRequires:  python-devel-tools >= 1:2.5
14 BuildRequires:  python-setuptools >= 0.6-0.c5
15 BuildRequires:  python3-devel
16 BuildRequires:  python3-devel-tools >= 1:2.5
17 BuildRequires:  python3-distribute
18 BuildRequires:  rpm-pythonprov
19 %pyrequires_eq  python-devel-tools
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 nose provides an alternate test discovery and running process for
25 unittest, one that is intended to mimic the behavior of py.test as
26 much as is reasonably possible without resorting to magic. By default,
27 nose will run tests in files or directories under the current working
28 directory whose names include "test". nose also supports doctest tests
29 and may optionally provide a test coverage report.
30
31 %description -l pl.UTF-8
32 nose dostarcza alternatywny proces wykrywania i uruchamiania testów
33 dla testów jednostkowych (unittest), mający przypominać zachowanie
34 py.test na ile to możliwe bez uciekania się do magii. Domyślnie nose
35 uruchamia testy z tych plików lub katalogów od bieżącego katalogu,
36 których nazwa zawiera "test". Obsługuje także testy doctest i
37 opcjonalnie przedstawia raport pokrycia testów.
38
39 %package -n     python3-%{module}
40 Summary:        Serial port interface module
41 Version:        %{version}
42 Release:        %{release}
43 Group:          Libraries/Python
44
45 %description -n python3-%{module}
46 nose provides an alternate test discovery and running process for
47 unittest, one that is intended to mimic the behavior of py.test as
48 much as is reasonably possible without resorting to magic. By default,
49 nose will run tests in files or directories under the current working
50 directory whose names include "test". nose also supports doctest tests
51 and may optionally provide a test coverage report.
52
53 %define _duplicate_files_terminate_build        0
54
55 %prep
56 %setup -qn %{module}-%{version}
57
58 %build
59 %{__python} setup.py build --build-base py2
60 %{__python3} setup.py build --build-base py3
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__python} setup.py build \
66         --build-base py2 \
67         install \
68         --root=$RPM_BUILD_ROOT \
69         --optimize=2
70
71 %{__python3} setup.py build \
72         --build-base py3 \
73         install \
74         --root=$RPM_BUILD_ROOT \
75         --optimize=2
76
77 mv $RPM_BUILD_ROOT%{_prefix}/man/ $RPM_BUILD_ROOT%{_datadir}
78
79 %py_postclean
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_bindir}/nosetests-2.7
87 %{py_sitescriptdir}/%{module}
88 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
89 %{_mandir}/man1/*
90
91 %files -n python3-%{module}
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/nosetests-3.?
94 %{py3_sitescriptdir}/%{module}
95 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
96 %{_mandir}/man1/*
This page took 0.058718 seconds and 2 git commands to generate.