]> git.pld-linux.org Git - packages/python-ndg-httpsclient.git/blob - python-ndg-httpsclient.spec
aef2409c072215220678377b2560501dfbf1cf20
[packages/python-ndg-httpsclient.git] / python-ndg-httpsclient.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  ndg-httpsclient
6 Summary:        Enhanced HTTPS support for httplib and urllib2 using PyOpenSSL
7 Summary(pl.UTF-8):      Rozszerzona obsługa HTTPS dla modułów httplib i urllib2 poprzez PyOpenSSL
8 Name:           python-%{module}
9 Version:        0.3.3
10 Release:        2
11 License:        BSD
12 Group:          Libraries/Python
13 Source0:        https://pypi.python.org/packages/source/n/ndg-httpsclient/ndg_httpsclient-%{version}.tar.gz
14 # Source0-md5:  c05794017dedee47b297185d82ef795e
15 URL:            http://ndg-security.ceda.ac.uk/wiki/ndg_httpsclient
16 BuildRequires:  python-distribute
17 BuildRequires:  python-pyOpenSSL
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 Requires:       python-modules
21 Requires:       python-pyOpenSSL
22 Requires:       python-pyasn1
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a HTTPS client implementation for httplib and urllib2 based on
28 PyOpenSSL. PyOpenSSL provides a more fully featured SSL implementation
29 over the default provided with Python and importantly enables full
30 verification of the SSL peer.
31
32 %description -l pl.UTF-8
33 Ten moduł to implementacja klienta HTTPS dla modułów httplib i urllib2
34 oparta na module PyOpenSSL. PyOpenSSL udostępnia pełniejszą
35 implementację SSL niż domyślnie dostarczana z Pythonem i umożliwia
36 pełną weryfikację drugiej strony połączenia SSL.
37
38 %prep
39 %setup -q -n ndg_httpsclient-%{version}
40
41 %build
42 %py_build %{?with_tests:test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %py_install
48
49 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
50 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
51 %py_postclean
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %attr(755,root,root) %{_bindir}/ndg_httpclient
59 %{py_sitescriptdir}/ndg
60 %if "%{py_ver}" > "2.4"
61 %{py_sitescriptdir}/ndg_httpsclient-%{version}-py*.egg-info
62 %{py_sitescriptdir}/ndg_httpsclient-%{version}-py*-nspkg.pth
63 %endif
This page took 0.08044 seconds and 2 git commands to generate.