]> git.pld-linux.org Git - packages/python-nbxmpp.git/blob - python-nbxmpp.spec
rebuild with python 3.10
[packages/python-nbxmpp.git] / python-nbxmpp.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          nbxmpp
7 Summary:        Non blocking Jabber/XMPP module
8 Name:           python-nbxmpp
9 Version:        0.6.6
10 Release:        5
11 License:        GPL v3
12 Group:          Libraries/Python
13 # https://dev.gajim.org/gajim/python-nbxmpp/tags
14 Source0:        https://files.pythonhosted.org/packages/source/n/%{module}/%{module}-%{version}.tar.gz
15 # Source0-md5:  e9e0ba25282c892c7618014bbf93244d
16 URL:            https://dev.gajim.org/gajim/python-nbxmpp
17 %if %{with python2}
18 BuildRequires:  python-setuptools
19 %endif
20 %if %{with python3}
21 BuildRequires:  python3-setuptools
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 Requires:       python-pyOpenSSL
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 python-nbxmpp is a Python library that provides a way for Python
31 applications to use Jabber/XMPP networks in a non-blocking way. This
32 library is initialy a fork of xmpppy one, but using non-blocking
33 sockets.
34
35 %package -n python3-%{module}
36 Summary:        Non blocking Jabber/XMPP module
37 Group:          Libraries/Python
38 Requires:       python3-pyOpenSSL
39
40 %description -n python3-%{module}
41 python-nbxmpp is a Python library that provides a way for Python
42 applications to use Jabber/XMPP networks in a non-blocking way. This
43 library is initialy a fork of xmpppy one, but using non-blocking
44 sockets.
45
46 %prep
47 %setup -q -n %{module}-%{version}
48
49 %build
50 %if %{with python2}
51 %py_build %{?with_tests:test}
52 %endif
53
54 %if %{with python3}
55 %py3_build %{?with_tests:test}
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %if %{with python2}
62 %py_install
63 %endif
64
65 %if %{with python3}
66 %py3_install
67 %endif
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc ChangeLog README
75 %{py_sitescriptdir}/%{module}
76 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
77
78 %files -n python3-%{module}
79 %defattr(644,root,root,755)
80 %doc ChangeLog README
81 %{py3_sitescriptdir}/%{module}
82 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.102568 seconds and 3 git commands to generate.