]> git.pld-linux.org Git - packages/python-musicbrainzngs.git/blob - python-musicbrainzngs.spec
f6300150a2dee6180ffc7600c13a6aba033de47a
[packages/python-musicbrainzngs.git] / python-musicbrainzngs.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Python 2 bindings for the MusicBrainz NGS and the Cover Art Archive webservices
7 Name:           python-musicbrainzngs
8 Version:        0.7.1
9 Release:        2
10 License:        BSD
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.python.org/simple/musicbrainzngs
13 Source0:        https://files.pythonhosted.org/packages/source/m/musicbrainzngs/musicbrainzngs-%{version}.tar.gz
14 # Source0-md5:  3bb83143ddf39a6e6b807a79b9ed97b5
15 URL:            https://python-musicbrainzngs.readthedocs.org/
16 %if %{with python2}
17 BuildRequires:  python-modules >= 1:2.7
18 BuildRequires:  python-setuptools
19 %endif
20 %if %{with python3}
21 BuildRequires:  python3-modules >= 1:3.3
22 BuildRequires:  python3-setuptools
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 Requires:       python-modules >= 1:2.7
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This library implements webservice bindings for the Musicbrainz NGS
32 site, also known as /ws/2 and the Cover Art Archive.
33
34 %package -n python3-musicbrainzngs
35 Summary:        Python 3 bindings for the MusicBrainz NGS and the Cover Art Archive webservices
36 Group:          Libraries/Python
37 Requires:       python3-modules >= 1:3.3
38
39 %description -n python3-musicbrainzngs
40 This library implements webservice bindings for the Musicbrainz NGS 
41 site, also known as /ws/2 and the Cover Art Archive.
42
43 %prep
44 %setup -q -n musicbrainzngs-%{version}
45
46 %build
47 %if %{with python2}
48 %py_build
49 %endif
50
51 %if %{with python3}
52 %py3_build
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %if %{with python2}
59 %py_install
60
61 %py_postclean
62 %endif
63
64 %if %{with python3}
65 %py3_install
66 %endif
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %if %{with python2}
72 %files
73 %defattr(644,root,root,755)
74 %doc CHANGES COPYING README.rst
75 %{py_sitescriptdir}/musicbrainzngs
76 %{py_sitescriptdir}/musicbrainzngs-%{version}-py*.egg-info
77 %endif
78
79 %if %{with python3}
80 %files -n python3-musicbrainzngs
81 %defattr(644,root,root,755)
82 %doc CHANGES COPYING README.rst
83 %{py3_sitescriptdir}/musicbrainzngs
84 %{py3_sitescriptdir}/musicbrainzngs-%{version}-py*.egg-info
85 %endif
This page took 0.068409 seconds and 2 git commands to generate.