]> git.pld-linux.org Git - packages/python-moksha-hub.git/blob - python-moksha-hub.spec
- release 2 (by relup.sh)
[packages/python-moksha-hub.git] / python-moksha-hub.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define module moksha.hub
6 Summary:        Hub components for Moksha
7 Name:           python-moksha-hub
8 Version:        1.4.6
9 Release:        2
10 License:        Apache v2.0
11 Group:          Development/Libraries
12 Source0:        http://pypi.python.org/packages/source/m/%{module}/%{module}-%{version}.tar.gz
13 # Source0-md5:  0ee9d3c3f0560bf392e4dcda1ccac9f9
14 URL:            http://pypi.python.org/pypi/moksha.hub
15 BuildRequires:  rpmbuild(macros) >= 1.710
16 BuildRequires:  python
17 BuildRequires:  python-modules
18 BuildRequires:  python-setuptools
19 BuildRequires:  rpm-pythonprov
20 %if %{with tests}
21 BuildRequires:  python-TwistedCore
22 BuildRequires:  python-daemon
23 BuildRequires:  python-devel
24 BuildRequires:  python-mock
25 BuildRequires:  python-moksha-common >= 1.0.6
26 BuildRequires:  python-nose
27 BuildRequires:  python-six
28 BuildRequires:  python-stomper
29 BuildRequires:  python-txws
30 BuildRequires:  python-txzmq
31 BuildRequires:  python-websocket-client
32 %endif
33 Requires:       python-TwistedCore
34 Requires:       python-daemon
35 Requires:       python-moksha-common >= 1.0.6
36 Requires:       python-six
37 Requires:       python-stomper
38 Requires:       python-txws
39 Requires:       python-txzmq
40 # When installed, these enable new plugins for the moksha.hub
41 #BuildRequires:  python-qpid
42 #Requires:       python-qpid
43 # Its a whole different package now.
44 Conflicts:      moksha < 1.0.0
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Hub components for Moksha.
50
51 %prep
52 %setup -q -n %{module}-%{version}
53
54 # Removed twisted from the list of deps in setup.py.
55 %{__sed} -i 's/"Twisted",//' setup.py
56
57 # *Experimental* support for python-zmq-13.0.0 in rawhide.
58 %{__sed} -i 's/pyzmq<=2.2.0.1/pyzmq/' setup.py
59
60 %build
61 %py_build
62
63 %if %{with tests}
64 %{__python} setup.py test
65 %endif
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %py_install
70
71 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/moksha/hub/tests
72
73 %py_postclean
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc README COPYING AUTHORS
81 %attr(755,root,root) %{_bindir}/moksha-hub
82 %{py_sitescriptdir}/moksha/hub
83 %{py_sitescriptdir}/moksha.hub-%{version}-py*-nspkg.pth
84 %{py_sitescriptdir}/moksha.hub-%{version}-py*.egg-info
This page took 0.082079 seconds and 3 git commands to generate.