]> git.pld-linux.org Git - packages/python-manuel.git/blob - python-manuel.spec
674d9064e5f8cde5d18da9299fa8960def4acdd7
[packages/python-manuel.git] / python-manuel.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Building tested documentation
8 Summary(pl.UTF-8):      Budowanie przetestowanej dokumentacji
9 Name:           python-manuel
10 Version:        1.10.1
11 Release:        2
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/manuel/
15 Source0:        https://files.pythonhosted.org/packages/source/m/manuel/manuel-%{version}.tar.gz
16 # Source0-md5:  5f481f0644df718f6154728444f0eb7d
17 URL:            https://pypi.org/project/manuel/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-six
23 BuildRequires:  python-zope.testing
24 %endif
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-modules >= 1:3.4
28 BuildRequires:  python3-setuptools
29 %if %{with tests}
30 BuildRequires:  python3-six
31 BuildRequires:  python3-zope.testing
32 %endif
33 %endif
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 Requires:       python-modules >= 1:2.7
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Manuel lets you build tested documentation.
42
43 %description -l pl.UTF-8
44 Manuel pozwala budować przetestowaną dokumentację.
45
46 %package -n python3-manuel
47 Summary:        Building tested documentation
48 Summary(pl.UTF-8):      Budowanie przetestowanej dokumentacji
49 Group:          Libraries/Python
50 Requires:       python3-modules >= 1:3.4
51
52 %description -n python3-manuel
53 Manuel lets you build tested documentation.
54
55 %description -n python3-manuel -l pl.UTF-8
56 Manuel pozwala budować przetestowaną dokumentację.
57
58 %package apidocs
59 Summary:        API documentation for Python manuel module
60 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona manuel
61 Group:          Documentation
62
63 %description apidocs
64 API documentation for Python manuel module.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API modułu Pythona manuel.
68
69 %prep
70 %setup -q -n manuel-%{version}
71
72 %build
73 %if %{with python2}
74 %py_build %{?with_tests:test}
75 %endif
76
77 %if %{with python3}
78 %py3_build %{?with_tests:test}
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %if %{with python2}
85 %py_install
86
87 %py_postclean
88 %endif
89
90 %if %{with python3}
91 %py3_install
92 %endif
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %if %{with python2}
98 %files
99 %defattr(644,root,root,755)
100 %doc CHANGES.rst COPYRIGHT.rst README.rst
101 %{py_sitescriptdir}/manuel
102 %{py_sitescriptdir}/manuel-%{version}-py*.egg-info
103 %endif
104
105 %if %{with python3}
106 %files -n python3-manuel
107 %defattr(644,root,root,755)
108 %doc CHANGES.rst COPYRIGHT.rst README.rst
109 %{py3_sitescriptdir}/manuel
110 %{py3_sitescriptdir}/manuel-%{version}-py*.egg-info
111 %endif
This page took 0.079431 seconds and 2 git commands to generate.