]> git.pld-linux.org Git - packages/python-logilab-astng.git/blob - python-logilab-astng.spec
- drop python3-distribute deps
[packages/python-logilab-astng.git] / python-logilab-astng.spec
1 # NOTE: for versions >= 1 see python-astroid.spec (module has been renamed)
2
3 # Conditional build:
4 %bcond_without  python2 # Python 2.x module
5 %bcond_without  python3 # Python 3.x module
6
7 %define module  logilab-astng
8 Summary:        Python Abstract Syntax Tree New Generation
9 Summary(pl.UTF-8):      Abstrakcyjne drzewa składniowe Pythona nowej generacji
10 Name:           python-logilab-astng
11 Version:        0.24.3
12 Release:        3
13 License:        LGPL v2.1+
14 Group:          Development/Languages/Python
15 Source0:        http://download.logilab.org/pub/astng/%{module}-%{version}.tar.gz
16 # Source0-md5:  11d9a33a00790dc30b851afbeaf1fb4e
17 URL:            http://www.logilab.org/projects/astng
18 %if %{with python2}
19 BuildRequires:  python-devel
20 BuildRequires:  python-modules >= 1:2.5
21 %endif
22 %if %{with python3}
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.710
25 BuildRequires:  python3-2to3
26 BuildRequires:  python3-devel
27 BuildRequires:  python3-modules >= 1:3.1
28 %endif
29 %pyrequires_eq  python-modules
30 Requires:       python-logilab-common >= 0.53.0
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The aim of this module is to provide a common base representation of
36 Python source code for projects such as pychecker, pyreverse,
37 pylint... Well, actually the development of this library is essentialy
38 governed by pylint's needs.
39
40 %description -l pl.UTF-8
41 Celem tego modułu jest dostarczenie wspólnej bazowej reprezentacji
42 kodu źródłowego Pythona dla projektów takich jak pychecker, pyreverse,
43 pylint... Właściwie tworzenie tej biblioteki jest istotnie kierowane
44 potrzebami pylinta.
45
46 %package -n python3-%{module}
47 Summary:        Python Abstract Syntax Tree New Generation
48 Summary(pl.UTF-8):      Abstrakcyjne drzewa składniowe Pythona nowej generacji
49 Group:          Development/Languages/Python
50 %pyrequires_eq  python3-modules
51 Requires:       python3-logilab-common >= 0.53.0
52
53 %description -n python3-%{module}
54 The aim of this module is to provide a common base representation of
55 Python source code for projects such as pychecker, pyreverse,
56 pylint... Well, actually the development of this library is essentialy
57 governed by pylint's needs.
58
59 %description -n python3-%{module} -l pl.UTF-8
60 Celem tego modułu jest dostarczenie wspólnej bazowej reprezentacji
61 kodu źródłowego Pythona dla projektów takich jak pychecker, pyreverse,
62 pylint... Właściwie tworzenie tej biblioteki jest istotnie kierowane
63 potrzebami pylinta.
64
65 %prep
66 %setup -q -n %{module}-%{version}
67 # drop python 2.5 egg deps
68 rm */*/*py2.5.egg
69
70 %build
71 %if %{with python2}
72 %py_build
73 %endif
74 %if %{with python3}
75 %py3_build --build-base=build3
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python3}
82 %py3_build --build-base=build3 install \
83         --optimize=2 \
84         --root=$RPM_BUILD_ROOT
85
86 # this file is packaged with python3-logilab-common
87 rm $RPM_BUILD_ROOT%{py3_sitescriptdir}/logilab/__init__.py
88 %endif
89
90 %if %{with python2}
91 %py_install
92
93 %py_postclean
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %if %{with python2}
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog README
103 %{py_sitescriptdir}/logilab/astng
104 %{py_sitescriptdir}/logilab_astng-%{version}-py*.egg-info
105 %{py_sitescriptdir}/logilab_astng-%{version}-py*-nspkg.pth
106 %endif
107
108 %if %{with python3}
109 %files -n python3-%{module}
110 %defattr(644,root,root,755)
111 %doc ChangeLog README
112 %{py3_sitescriptdir}/logilab/astng
113 %{py3_sitescriptdir}/logilab_astng-%{version}-py*.egg-info
114 %{py3_sitescriptdir}/logilab_astng-%{version}-py*-nspkg.pth
115 %endif
This page took 0.057966 seconds and 3 git commands to generate.