]> git.pld-linux.org Git - packages/python-livereload.git/blob - python-livereload.spec
d500415d7fee447d18b811ce134528fdb106dcea
[packages/python-livereload.git] / python-livereload.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        LiveReload - tool for web developers
7 Summary(pl.UTF-8):      LiveReload - narzędzie dla programistów WWW
8 Name:           python-livereload
9 Version:        2.6.0
10 Release:        2
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/livereload/
14 Source0:        https://files.pythonhosted.org/packages/source/l/livereload/livereload-%{version}.tar.gz
15 # Source0-md5:  99b72147b9a9bc37835a649e7a039a5a
16 URL:            https://github.com/lepture/python-livereload
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.5
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.7
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Python LiveReload is an awesome tool for web developers.
33
34 %description -l pl.UTF-8
35 Python LiveReload jest niesamowitym narzędziem dla programistów WWW.
36
37 %package -n python3-livereload
38 Summary:        LiveReload - tool for web developers
39 Summary(pl.UTF-8):      LiveReload - narzędzie dla programistów WWW
40 Group:          Libraries/Python
41 Requires:       python3-modules >= 1:3.5
42
43 %description -n python3-livereload
44 Python LiveReload is an awesome tool for web developers.
45
46 %description -n python3-livereload -l pl.UTF-8
47 Python LiveReload jest niesamowitym narzędziem dla programistów WWW.
48
49 %prep
50 %setup -q -n livereload-%{version}
51
52 %build
53 %if %{with python2}
54 %py_build
55 %endif
56
57 %if %{with python3}
58 %py3_build
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %if %{with python3}
65 %py3_install
66
67 %{__mv} $RPM_BUILD_ROOT%{_bindir}/livereload{,-3}
68 %endif
69
70 %if %{with python2}
71 %py_install
72
73 %py_postclean
74 %endif
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %if %{with python2}
80 %files
81 %defattr(644,root,root,755)
82 %doc LICENSE README.rst
83 %attr(755,root,root) %{_bindir}/livereload
84 %{py_sitescriptdir}/livereload
85 %{py_sitescriptdir}/livereload-%{version}-py*.egg-info
86 %endif
87
88 %if %{with python3}
89 %files -n python3-livereload
90 %defattr(644,root,root,755)
91 %doc LICENSE README.rst
92 %attr(755,root,root) %{_bindir}/livereload-3
93 %{py3_sitescriptdir}/livereload
94 %{py3_sitescriptdir}/livereload-%{version}-py*.egg-info
95 %endif
This page took 0.0578379999999999 seconds and 2 git commands to generate.