]> git.pld-linux.org Git - packages/python-linda.git/blob - python-linda.spec
- initial
[packages/python-linda.git] / python-linda.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         module linda
4
5 Summary:        Simple Python implementation of a linda system
6 Summary(pl):    Prosta implementacja systemu linda w Pythonie
7 Name:           python-%{module}
8 Version:        0.2
9 Release:        1
10 License:        LGPL
11 Group:          Libraries/Python
12 Source0:        http://www-users.cs.york.ac.uk/~aw/pylinda/%{module}-%{version}.tar.gz
13 # Source0-md5:  396d2908f530293d8390638639eb3198
14 Patch0:         pylinda-server-first-line-path.patch
15 URL:            http://www-users.cs.york.ac.uk/~aw/pylinda
16 BuildRequires:  python-devel >= 2.3
17 Requires:       python >= 2.3
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Linda is an widely studied distributed computing environment, centered
23 around the notion of a tuple space. A tuple space is a bag (also
24 called a multi-set) of tuples. A tuple is an ordered, typed chunk of
25 data. Tuple spaces exist independently of processes in the system, and
26 the data placed into a tuple space also exist independently. See
27 "Generative communication in Linda" (1985) and "Multiple tuple spaces
28 in Linda" both by David Gelernter for more information on Linda.
29
30 PyLinda is a simple implementation of a linda system, however it also
31 includes several of the more recently proposed extensions to Linda in
32 the form of multiple tuple spaces, garbage collection, sane
33 non-blocking primitives and bulk tuple operations.
34
35 This package contains pylinda libraries, which are necessary for running
36 pylinda servers and developing client programs.
37
38 %description -l pl
39 Lidna jest poddawanym g³êbokiej analizie ¶rodowiskiem komputerowego
40 przetwarzania danych, skupiaj±cym siê na notacji przestrzeni krotek.
41 Przestreñ krotek jest zbiorem (a w³a¶ciwie - multizbiorem) krotek.
42 Krotka jest uporz±dkowanym i utypowionym zestawem danych. Przestrzenie
43 krotek istniej± w systemie niezale¿nie od procesów, a dane umieszczone
44 w przestrzeni krotek tak¿e s± niezale¿ne od procesów. Wiêcej
45 informacji mo¿na znale¼æ w dzie³ach "Generative communication in
46 Linda" (1985) i "Multiple tuple spaces in Linda" autorstwa Daviad
47 Gelerntera.
48
49 PyLinda jest prost± implementacj± ¶rodowiska Linda. Pomimo swojej
50 prostoty zawiera jednak pewn± liczbê najczê¶cie spotykanych rozszerzeñ
51 Lindy, takich jak wielokrotne przestrzenie krotek, od¶miecanie
52 pamiêci, rozs±dnie zaprojektowane nieblokuj±ce operacje pierwotne oraz
53 ca³± masê z³o¿onych operacji na krotkach.
54
55 Ten pakiet zawiera biblioteki pakietu pylinda, niezbêdne do
56 uruchomienia serwerów oraz rozwijania programów klienckich pylindy.
57
58 %package -n pylinda-server
59 Summary:        Server program for pylinda computing environment
60 Summary(pl):    Program serwera ¶rodowika pylinda
61 Group:          Applications/Science
62 Requires:       %{name} = %{version}-%{release}
63
64 %description -n pylinda-server
65 This package contains server program for pylinda computing
66 environment.
67
68 %description -n pylinda-server -l pl
69 Program serwera ¶rodowiska pylinda.
70
71 %package doc
72 Summary:        Documentation for pylinda computing environment
73 Summary(pl):    Dokumentcja ¶rodowiska pylinda
74 Group:          Libraries/Python
75 Requires:       %{name} = %{version}-%{release}
76
77 %description doc
78 This package contains documentation files for pylinda computing
79 environment.
80
81 %description doc -l pl
82 Pakiet zawieraj±cy dokumentacjê ¶rodowiska pylinda.
83
84 %package examples
85 Summary:        Example programs for pylinda computing environment
86 Summary(pl):    Programy przyk³adowe do ¶rodowiska pylinda
87 Group:          Libraries/Python
88 Requires:       %{name} = %{version}-%{release}
89
90 %description examples
91 This package contains example programs for pylinda computing
92 environment.
93
94 %description examples -l pl
95 Pakiet zawieraj±cy programy przyk³adowe do ¶rodowiska pylinda.
96
97 %prep
98 %setup -q -n %{module}-%{version}
99 %patch0 -p0
100
101 %build
102 python setup.py build_ext
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_examplesdir}/%{name}-%{version},%{_bindir}}
107
108 python setup.py install \
109         --root=$RPM_BUILD_ROOT \
110         --install-lib=%{py_sitescriptdir} \
111         --optimize=2
112
113 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
114
115 cp -ar examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
116 cp -a linda_server.py $RPM_BUILD_ROOT%{_bindir}
117
118 rm -rf $RPM_BUILD_ROOT%{_datadir}/pylinda
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc README
126 %{py_sitescriptdir}/linda
127
128 %files doc
129 %defattr(644,root,root,755)
130 %doc doc/html/*
131
132 %files examples
133 %defattr(644,root,root,755)
134 %{_examplesdir}/%{name}-%{version}
135
136 %files -n pylinda-server
137 %defattr(755,root,root,755)
138 %{_bindir}/linda_server.py
This page took 0.039463 seconds and 4 git commands to generate.