]> git.pld-linux.org Git - packages/python-linda.git/blob - python-linda.spec
- removed %%include /usr/lib/rpm/macros.python
[packages/python-linda.git] / python-linda.spec
1
2 %define         module  linda
3
4 Summary:        Simple Python implementation of a linda system
5 Summary(pl):    Prosta implementacja systemu linda w Pythonie
6 Name:           python-%{module}
7 Version:        0.3
8 Release:        1
9 License:        LGPL
10 Group:          Libraries/Python
11 Source0:        http://www-users.cs.york.ac.uk/~aw/pylinda/%{module}-%{version}.tar.gz
12 # Source0-md5:  a3a37b7263e6ddb0b6ebae01700c9cdd
13 URL:            http://www-users.cs.york.ac.uk/~aw/pylinda
14 BuildRequires:  python-devel >= 2.3
15 Requires:       python >= 2.3
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Linda is an widely studied distributed computing environment, centered
20 around the notion of a tuple space. A tuple space is a bag (also
21 called a multi-set) of tuples. A tuple is an ordered, typed chunk of
22 data. Tuple spaces exist independently of processes in the system, and
23 the data placed into a tuple space also exist independently. See
24 "Generative communication in Linda" (1985) and "Multiple tuple spaces
25 in Linda" both by David Gelernter for more information on Linda.
26
27 PyLinda is a simple implementation of a linda system, however it also
28 includes several of the more recently proposed extensions to Linda in
29 the form of multiple tuple spaces, garbage collection, sane
30 non-blocking primitives and bulk tuple operations.
31
32 This package contains pylinda libraries, which are necessary for running
33 pylinda servers and developing client programs.
34
35 %description -l pl
36 Linda jest poddawanym g³êbokiej analizie ¶rodowiskiem komputerowego
37 przetwarzania danych, skupiaj±cym siê na notacji przestrzeni krotek.
38 Przestrzeñ krotek jest zbiorem (a w³a¶ciwie - multizbiorem) krotek.
39 Krotka jest uporz±dkowanym i utypowionym zestawem danych. Przestrzenie
40 krotek istniej± w systemie niezale¿nie od procesów, a dane umieszczone
41 w przestrzeni krotek tak¿e s± niezale¿ne od procesów. Wiêcej
42 informacji mo¿na znale¼æ w dzie³ach "Generative communication in
43 Linda" (1985) i "Multiple tuple spaces in Linda" autorstwa Davida
44 Gelerntera.
45
46 PyLinda jest prost± implementacj± ¶rodowiska Linda. Pomimo swojej
47 prostoty zawiera jednak pewn± liczbê najczê¶ciej spotykanych rozszerzeñ
48 Lindy, takich jak wielokrotne przestrzenie krotek, od¶miecanie
49 pamiêci, rozs±dnie zaprojektowane nieblokuj±ce operacje pierwotne oraz
50 ca³± masê z³o¿onych operacji na krotkach.
51
52 Ten pakiet zawiera biblioteki pakietu pylinda, niezbêdne do
53 uruchomienia serwerów oraz rozwijania programów klienckich pylindy.
54
55 %package -n pylinda-server
56 Summary:        Server program for pylinda computing environment
57 Summary(pl):    Program serwera ¶rodowiska pylinda
58 Group:          Applications/Science
59 Requires:       %{name} = %{version}-%{release}
60
61 %description -n pylinda-server
62 This package contains server program for pylinda computing
63 environment.
64
65 %description -n pylinda-server -l pl
66 Program serwera ¶rodowiska pylinda.
67
68 %package doc
69 Summary:        Documentation for pylinda computing environment
70 Summary(pl):    Dokumentcja ¶rodowiska pylinda
71 Group:          Libraries/Python
72 Requires:       %{name} = %{version}-%{release}
73
74 %description doc
75 This package contains documentation files for pylinda computing
76 environment.
77
78 %description doc -l pl
79 Pakiet zawieraj±cy dokumentacjê ¶rodowiska pylinda.
80
81 %package examples
82 Summary:        Example programs for pylinda computing environment
83 Summary(pl):    Programy przyk³adowe do ¶rodowiska pylinda
84 Group:          Libraries/Python
85 Requires:       %{name} = %{version}-%{release}
86
87 %description examples
88 This package contains example programs for pylinda computing
89 environment.
90
91 %description examples -l pl
92 Pakiet zawieraj±cy programy przyk³adowe do ¶rodowiska pylinda.
93
94 %prep
95 %setup -q -n %{module}-%{version}
96
97 %build
98 python setup.py build_ext
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version},%{_bindir}}
103
104 python setup.py install \
105         --root=$RPM_BUILD_ROOT \
106         --install-lib=%{py_sitedir} \
107         --optimize=2
108
109 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py -exec rm {} \;
110
111 cp -ar examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112 cp -a linda_server.py $RPM_BUILD_ROOT%{_bindir}
113
114 rm -rf $RPM_BUILD_ROOT%{_datadir}/pylinda
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc README
122 %attr(755,root,root) %{py_sitedir}/shm.so
123 %{py_sitedir}/linda
124
125 %files doc
126 %defattr(644,root,root,755)
127 %doc doc/html/*
128
129 %files examples
130 %defattr(644,root,root,755)
131 %{_examplesdir}/%{name}-%{version}
132
133 %files -n pylinda-server
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/linda_server.py
This page took 0.056795 seconds and 4 git commands to generate.