]> git.pld-linux.org Git - packages/python-libvirt.git/blob - python-libvirt.spec
cfc5d11ccc30805a656416205bf164584ece1b8a
[packages/python-libvirt.git] / python-libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  lxc             # LXC support
4 %bcond_without  qemu            # Qemu support
5
6 # qemu available only on x86 and ppc
7 %ifnarch %{ix86} %{x8664} ppc
8 %undefine       with_qemu
9 %endif
10 # Xen is available only on x86 and ia64
11 %ifnarch %{ix86} %{x8664} ia64
12 %undefine       with_xen
13 %endif
14
15 %define         origname        libvirt-python
16 Summary:        Python bindings to interact with virtualization capabilities
17 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
18 Name:           python-libvirt
19 Version:        1.2.0
20 Release:        0.1
21 License:        LGPL v2.1+
22 Group:          Development/Languages/Python
23 Source0:        ftp://ftp.libvirt.org/libvirt/python/%{origname}-%{version}.tar.gz
24 # Source0-md5:  38158e5740be65f17eef9f99ffa5dadf
25 URL:            http://www.libvirt.org/
26 BuildRequires:  libvirt-devel
27 BuildRequires:  python
28 BuildRequires:  python-devel
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.627
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Libvirt is a C toolkit to interact with the virtualization
35 capabilities of recent versions of Linux.
36
37 This package contains the Python bindings for the libvirt library.
38
39 %description -l pl.UTF-8
40 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
41 obecnych wersji Linuksa.
42
43 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
44
45 %prep
46 %setup -q -n %{origname}-%{version}
47
48 %build
49 %{__python} setup.py build
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__python} setup.py install \
54         --root=$RPM_BUILD_ROOT
55
56 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
57 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
58 %py_postclean
59 #{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc AUTHORS ChangeLog README NEWS
67 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
68 %{py_sitedir}/libvirt.py[co]
69 %if %{with lxc}
70 %attr(755,root,root) %{py_sitedir}/libvirtmod_lxc.so
71 %{py_sitedir}/libvirt_lxc.py[co]
72 %endif
73 %if %{with qemu}
74 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
75 %{py_sitedir}/libvirt_qemu.py[co]
76 %endif
This page took 0.07365 seconds and 2 git commands to generate.