]> git.pld-linux.org Git - packages/python-lhafile.git/blob - python-lhafile.spec
485de6b659632d329bc656179ffa21a156b65fb9
[packages/python-lhafile.git] / python-lhafile.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        LHA (.lzh) file extract interface
7 Summary(pl.UTF-8):      Interfejs do rozpakowywania plików LHA (.lzh)
8 Name:           python-lhafile
9 Version:        0.2.2
10 Release:        5
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/lhafile/
14 Source0:        https://files.pythonhosted.org/packages/source/l/lhafile/lhafile-%{version}.tar.gz
15 # Source0-md5:  5d916030a6623c12d12a1e4e05cb8939
16 URL:            https://pypi.org/project/lhafile/
17 %if %{with python2}
18 BuildRequires:  python-devel >= 1:2.5
19 %endif
20 %if %{with python3}
21 BuildRequires:  python3-devel >= 1:3.2
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 Requires:       python-modules >= 1:2.5
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Extract LHA (.lzh) file extension. The interface is similar to the
30 zipfile module in the regular Python distribution.
31
32 %description -l pl.UTF-8
33 Rozszerzenie Pythona do rozpakowywania plików LHA (.lzh). Interfejs
34 jest podobny do modułu zipfile z dystrybucji Pythona.
35
36 %package -n python3-lhafile
37 Summary:        LHA (.lzh) file extract interface
38 Summary(pl.UTF-8):      Interfejs do rozpakowywania plików LHA (.lzh)
39 Group:          Libraries/Python
40 Requires:       python3-modules >= 1:3.2
41
42 %description -n python3-lhafile
43 Extract LHA (.lzh) file extension. The interface is similar to the
44 zipfile module in the regular Python distribution.
45
46 %description -n python3-lhafile -l pl.UTF-8
47 Rozszerzenie Pythona do rozpakowywania plików LHA (.lzh). Interfejs
48 jest podobny do modułu zipfile z dystrybucji Pythona.
49
50 %prep
51 %setup -q -n lhafile-%{version}
52
53 %build
54 %if %{with python2}
55 %py_build
56 %endif
57
58 %if %{with python3}
59 %py3_build
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %if %{with python2}
66 %py_install
67
68 %py_postclean
69 %endif
70
71 %if %{with python3}
72 %py3_install
73 %endif
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %if %{with python2}
79 %files
80 %defattr(644,root,root,755)
81 %doc COPYING.txt README
82 %{py_sitedir}/lhafile
83 %attr(755,root,root) %{py_sitedir}/lzhlib.so
84 %{py_sitedir}/lhafile-%{version}-py*.egg-info
85 %endif
86
87 %if %{with python3}
88 %files -n python3-lhafile
89 %defattr(644,root,root,755)
90 %doc COPYING.txt README
91 %{py3_sitedir}/lhafile
92 %attr(755,root,root) %{py3_sitedir}/lzhlib.cpython-*.so
93 %{py3_sitedir}/lhafile-%{version}-py*.egg-info
94 %endif
This page took 0.061886 seconds and 2 git commands to generate.