]> git.pld-linux.org Git - packages/python-ldap.git/blob - python-ldap.spec
ab320bd11e3808c12100af44606e65a74fa3f77e
[packages/python-ldap.git] / python-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module  ldap
6 Summary:        LDAP client API for Python
7 Summary(pl.UTF-8):      API klienckie LDAP dla Pythona
8 Name:           python-%{module}
9 Version:        2.4.32
10 Release:        1
11 Epoch:          1
12 License:        Python-like
13 Group:          Libraries/Python
14 Source0:        https://pypi.python.org/packages/67/d9/fa0ea70d1792875745116ad62ac8d4bcb07550b15cded591bb57df6a6d9a/%{name}-%{version}.tar.gz
15 # Source0-md5:  7c46c8a04acc227a778c7900c87cdfc7
16 Patch0:         %{name}-sasl2.patch
17 URL:            http://python-ldap.sourceforge.net/
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 BuildRequires:  cyrus-sasl >= 2.1.0
20 BuildRequires:  openldap-devel >= 2.4.6
21 BuildRequires:  python-devel >= 1:2.5
22 BuildRequires:  python-modules >= 1:2.5
23 BuildRequires:  rpm-pythonprov
24 Requires:       python-modules
25 Provides:       ldapmodule
26 Obsoletes:      ldapmodule
27 Obsoletes:      python-ldapmodule
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 python-ldap provides an object-oriented API to access LDAP directory
32 servers from Python programs. Mainly it wraps the OpenLDAP client libs
33 for that purpose.
34
35 Additionally the package contains modules for other LDAP-related stuff
36 (e.g. processing LDIF, LDAPURLs, LDAPv3 sub-schema, etc.).
37
38 %description -l pl.UTF-8
39 Moduł python-ldap dostarcza zorientowane obiektowo API pozwalające na
40 dostęp do usług katalogowych LDAP z poziomu programów w Pythonie.
41 Głównie obudowuje w tym celu biblioteki klienckie OpenLDAP.
42
43 Dodatkowo pakiet zawiera moduły do innych zadań związanych z LDAP (jak
44 przetwarzanie LDIF, LDAPURL, podschematy LDAPv3 itp.).
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 %py_build
52
53 %if %{with tests}
54 %{__python} setup.py test
55
56 LDAPNOINIT=1 \
57 PYTHONPATH=$(echo build-2/lib.linux-*/) \
58 %{__python} -c "import ldap; print ldap.__version__; ldapo = ldap.initialize('ldap://localhost')"
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 #PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir}
64 %py_install
65
66 %py_postclean
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CHANGES LICENCE README TODO
74 %attr(755,root,root) %{py_sitedir}/_ldap.so
75 %{py_sitedir}/dsml.py[co]
76 %{py_sitedir}/ldapurl.py[co]
77 %{py_sitedir}/ldif.py[co]
78 %{py_sitedir}/ldap
79 %{py_sitedir}/python_ldap-%{version}-py*.egg-info
This page took 0.052355 seconds and 2 git commands to generate.