]> git.pld-linux.org Git - packages/python-lazy-object-proxy.git/blob - python-lazy-object-proxy.spec
6963ab18ac00e342731048458fca305b2e11bca9
[packages/python-lazy-object-proxy.git] / python-lazy-object-proxy.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  lazy-object-proxy
8 Summary:        A fast and thorough lazy object proxy
9 Summary(pl.UTF-8):      Szybkie i gruntowne leniwe proxy obiektów
10 Name:           python-%{module}
11 Version:        1.4.3
12 Release:        3
13 License:        BSD
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/lazy-object-proxy/
16 Source0:        https://files.pythonhosted.org/packages/source/l/lazy-object-proxy/%{module}-%{version}.tar.gz
17 # Source0-md5:  5c64c06affcd2a7c6ddc848af4280cca
18 URL:            https://github.com/ionelmc/python-lazy-object-proxy
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with python2}
22 BuildRequires:  python-devel >= 1:2.7
23 BuildRequires:  python-setuptools >= 30.3.0
24 BuildRequires:  python-setuptools_scm >= 3.3.1
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-devel >= 1:3.4
28 BuildRequires:  python3-setuptools >= 30.3.0
29 BuildRequires:  python3-setuptools_scm >= 3.3.1
30 %endif
31 %if %{with doc}
32 BuildRequires:  python3-sphinx_py3doc_enhanced_theme
33 BuildRequires:  sphinx-pdg-3 >= 1.3
34 %endif
35 Requires:       python-modules >= 1:2.7
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A fast and thorough lazy object proxy.
40
41 %description -l pl.UTF-8
42 Szybkie i gruntowne leniwe proxy obiektów.
43
44 %package -n python3-%{module}
45 Summary:        A fast and thorough lazy object proxy
46 Summary(pl.UTF-8):      Szybkie i gruntowne leniwe proxy obiektów
47 Group:          Libraries/Python
48 Requires:       python3-modules >= 1:3.4
49
50 %description -n python3-%{module}
51 A fast and thorough lazy object proxy.
52
53 %description -n python3-%{module} -l pl.UTF-8
54 Szybkie i gruntowne leniwe proxy obiektów.
55
56 %package apidocs
57 Summary:        API documentation for lazy_object_proxy module
58 Summary(pl.UTF-8):      Dokumentacja API modułu lazy_object_proxy
59 Group:          Documentation
60
61 %description apidocs
62 API documentation for lazy_object_proxy module.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API modułu lazy_object_proxy.
66
67 %prep
68 %setup -q -n %{module}-%{version}
69
70 %build
71 %if %{with python2}
72 %py_build
73 %endif
74
75 %if %{with python3}
76 %py3_build
77 %endif
78
79 %if %{with doc}
80 sphinx-build-3 -b html docs docs/_build
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %if %{with python2}
87 %py_install
88
89 %py_postclean
90 %endif
91
92 %if %{with python3}
93 %py3_install
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %if %{with python2}
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS.rst CHANGELOG.rst LICENSE README.rst
103 %dir %{py_sitedir}/lazy_object_proxy
104 %{py_sitedir}/lazy_object_proxy/*.py[co]
105 %attr(755,root,root) %{py_sitedir}/lazy_object_proxy/cext.so
106 %{py_sitedir}/lazy_object_proxy-%{version}-py*.egg-info
107 %endif
108
109 %if %{with python3}
110 %files -n python3-%{module}
111 %defattr(644,root,root,755)
112 %doc AUTHORS.rst CHANGELOG.rst LICENSE README.rst
113 %dir %{py3_sitedir}/lazy_object_proxy
114 %{py3_sitedir}/lazy_object_proxy/*.py
115 %attr(755,root,root) %{py3_sitedir}/lazy_object_proxy/cext.cpython-*.so
116 %{py3_sitedir}/lazy_object_proxy/__pycache__
117 %{py3_sitedir}/lazy_object_proxy-%{version}-py*.egg-info
118 %endif
119
120 %if %{with doc}
121 %files apidocs
122 %defattr(644,root,root,755)
123 %doc docs/_build/{_static,*.html,*.js}
124 %endif
This page took 0.064934 seconds and 2 git commands to generate.