]> git.pld-linux.org Git - packages/python-kitchen.git/blob - python-kitchen.spec
- release 3 (by relup.sh)
[packages/python-kitchen.git] / python-kitchen.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  kitchen
6 Summary:        Small, useful pieces of code to make Python coding easier
7 Name:           python-%{module}
8 Version:        1.1.1
9 Release:        3
10 License:        LGPL v2+
11 Group:          Development/Languages
12 Source0:        https://fedorahosted.org/releases/k/i/kitchen/%{module}-%{version}.tar.gz
13 # Source0-md5:  059d7ce048ca1d0fb53e6755145137b0
14 URL:            https://fedorahosted.org/kitchen/
15 BuildRequires:  python-modules >= 2.3.1
16 BuildRequires:  python-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 %if %{with tests}
20 BuildRequires:  python-chardet
21 BuildRequires:  python-coverage
22 BuildRequires:  python-nose
23 %if %(locale -a | grep -q '^en_US$'; echo $?)
24 BuildRequires:  glibc-localedb-all
25 %endif
26 %endif
27 Suggests:       python-chardet
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 kitchen includes functions to make gettext easier to use, handling
33 unicode text easier (conversion with bytes, outputting xml, and
34 calculating how many columns a string takes), and compatibility
35 modules for writing code that uses Python 2.7 modules but needs to run
36 on Python 2.3
37
38 %prep
39 %setup -q -n %{module}-%{version}
40
41 # can't find origin of this import
42 grep -r 'from test import test_support' tests -l | xargs rm
43
44 %build
45 %py_build
46
47 %if %{with tests}
48 nosetests-%{py_ver} --with-coverage --cover-package kitchen
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %py_install
54
55 %py_postclean
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc COPYING README NEWS COPYING.LESSER docs
63 %dir %{py_sitescriptdir}/kitchen
64 %{py_sitescriptdir}/kitchen/*.py[co]
65 %{py_sitescriptdir}/kitchen/collections
66 %{py_sitescriptdir}/kitchen/i18n
67 %{py_sitescriptdir}/kitchen/iterutils
68 %{py_sitescriptdir}/kitchen/pycompat24
69 %{py_sitescriptdir}/kitchen/pycompat25
70 %{py_sitescriptdir}/kitchen/pycompat27
71 %{py_sitescriptdir}/kitchen/text
72 %{py_sitescriptdir}/kitchen/versioning
73 %if "%{py_ver}" > "2.4"
74 %{py_sitescriptdir}/kitchen-%{version}*.egg-info
75 %endif
This page took 0.049311 seconds and 3 git commands to generate.