]> git.pld-linux.org Git - packages/python-keystoneauth1.git/blob - python-keystoneauth1.spec
- release 4 (by relup.sh)
[packages/python-keystoneauth1.git] / python-keystoneauth1.spec
1 #
2 # TODO:
3 #       - enable 'extras' - kerberos and betamax (both require new dependecies)
4
5 # Conditional build:
6 %bcond_with     doc     # build doc
7 %bcond_with     tests   # do perform "make test" (requires tons of dependencies)
8 %bcond_without  python2 # CPython 2.x module
9 %bcond_without  python3 # CPython 3.x module
10
11 Summary:        Authentication Library for OpenStack Identity
12 Name:           python-keystoneauth1
13 Version:        3.1.0
14 Release:        4
15 License:        Apache
16 Group:          Libraries/Python
17 Source0:        https://pypi.python.org/packages/60/84/563732a068310ee9a8c3626a037efea22b3a926431d91f1ec991db89a70e/keystoneauth1-%{version}.tar.gz
18 # Source0-md5:  ddfb0d140292a22969b4bcbe08e5df12
19 URL:            https://docs.openstack.org/keystoneauth/latest/
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 %if %{with python2}
23 BuildRequires:  python-pbr >= 2.0.0
24 BuildRequires:  python-setuptools
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-pbr >= 2.0.0
28 BuildRequires:  python3-setuptools
29 %endif
30 Requires:       python-iso8601 >= 0.1.11
31 Requires:       python-pbr >= 2.0.0
32 Requires:       python-positional >= 1.1.1
33 Requires:       python-requests >= 2.14.2
34 Requires:       python-six >= 1.9.0
35 Requires:       python-stevedore >= 1.20.0
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This package contains tools for authenticating to an OpenStack-based
41 cloud. These tools include:
42
43 - Authentication plugins (password, token, and federation based)
44 - Discovery mechanisms to determine API version support
45 - A session that is used to maintain client settings across requests
46   (based on the requests Python library)
47
48 %package -n python3-keystoneauth1
49 Summary:        Authentication Library for OpenStack Identity
50 Group:          Libraries/Python
51 Requires:       python3-iso8601 >= 0.1.11
52 Requires:       python3-modules
53 Requires:       python3-pbr >= 2.0.0
54 Requires:       python3-positional >= 1.1.1
55 Requires:       python3-requests >= 2.14.2
56 Requires:       python3-six >= 1.9.0
57 Requires:       python3-stevedore >= 1.20.0
58
59 %description -n python3-keystoneauth1
60 This package contains tools for authenticating to an OpenStack-based
61 cloud. These tools include:
62
63 - Authentication plugins (password, token, and federation based)
64 - Discovery mechanisms to determine API version support
65 - A session that is used to maintain client settings across requests
66   (based on the requests Python library)
67
68 %package apidocs
69 Summary:        API documentation for Python keystoneauth1 module
70 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona keystoneauth1
71 Group:          Documentation
72
73 %description apidocs
74 API documentation for Pythona keystoneauth1 module.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API modułu Pythona keystoneauth1.
78
79 %prep
80 %setup -q -n keystoneauth1-%{version}
81
82 %build
83 %if %{with python2}
84 %py_build %{?with_tests:test}
85 %endif
86
87 %if %{with python3}
88 %py3_build %{?with_tests:test}
89 %endif
90
91 %if %{with doc}
92 cd doc
93 %{__make} -j1 html
94 rm -rf _build/html/_sources
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %if %{with python2}
101 %py_install
102
103 # when files are installed in other way that standard 'setup.py
104 # they need to be (re-)compiled
105 # change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
106 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
107 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
108
109 %py_postclean
110 %endif
111
112 %if %{with python3}
113 %py3_install
114 %endif
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %if %{with python2}
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog README.rst
123 %{py_sitescriptdir}/keystoneauth1
124 %{py_sitescriptdir}/keystoneauth1-%{version}-py*.egg-info
125 %endif
126
127 %if %{with python3}
128 %files -n python3-keystoneauth1
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog README.rst
131 %{py3_sitescriptdir}/keystoneauth1
132 %{py3_sitescriptdir}/keystoneauth1-%{version}-py*.egg-info
133 %endif
134
135 %if %{with doc}
136 %files apidocs
137 %defattr(644,root,root,755)
138 %doc docs/_build/html/*
139 %endif
This page took 0.109969 seconds and 3 git commands to generate.