]> git.pld-linux.org Git - packages/python-keepalive.git/blob - python-keepalive.spec
- new
[packages/python-keepalive.git] / python-keepalive.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Python 2 HTTP handler for urllib2 that supports HTTP 1.1 and keepalive
7 Summary(pl.UTF-8):      Klasa Pythona 2 obsługująca HTTP dla urllib2 z obsługą HTTP 1.1 i keepalive
8 Name:           python-keepalive
9 Version:        0.5
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries/Python
13 #Source0Download: https://github.com/wikier/keepalive/releases
14 Source0:        https://github.com/wikier/keepalive/archive/%{version}/keepalive-%{version}.tar.gz
15 # Source0-md5:  493d1c161cec22df7e90cb5d57b98187
16 URL:            https://github.com/wikier/keepalive
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.6
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-2to3 >= 1:3.3
25 BuildRequires:  python3-modules >= 1:3.3
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 1:2.6
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 An HTTP handler for urllib2 that supports HTTP 1.1 and keepalive.
34
35 %description -l pl.UTF-8
36 Klasa obsługująca HTTP dla modułu urllib2 z obsługą HTTP 1.1 oraz
37 keepalive.
38
39 %package -n python3-keepalive
40 Summary:        Python 3 HTTP handler for urllib2 that supports HTTP 1.1 and keepalive
41 Summary(pl.UTF-8):      Klasa Pythona 3 obsługująca HTTP dla urllib2 z obsługą HTTP 1.1 i keepalive
42 Group:          Libraries/Python
43 Requires:       python3-modules >= 1:3.3
44
45 %description -n python3-keepalive
46 An HTTP handler for urllib2 that supports HTTP 1.1 and keepalive.
47
48 %description -n python3-keepalive -l pl.UTF-8
49 Klasa obsługująca HTTP dla modułu urllib2 z obsługą HTTP 1.1 oraz
50 keepalive.
51
52 %prep
53 %setup -q -n keepalive-%{version}
54
55 %build
56 %if %{with python2}
57 %py_build
58 %endif
59
60 %if %{with python3}
61 %py3_build
62 %endif
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %if %{with python2}
68 %py_install
69
70 %py_postclean
71 %endif
72
73 %if %{with python3}
74 %py3_install
75 %endif
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with python2}
81 %files
82 %defattr(644,root,root,755)
83 %doc README.md
84 %{py_sitescriptdir}/keepalive
85 %{py_sitescriptdir}/keepalive-%{version}-py*.egg-info
86 %endif
87
88 %if %{with python3}
89 %files -n python3-keepalive
90 %defattr(644,root,root,755)
91 %doc README.md
92 %{py3_sitescriptdir}/keepalive
93 %{py3_sitescriptdir}/keepalive-%{version}-py*.egg-info
94 %endif
This page took 0.065279 seconds and 3 git commands to generate.