]> git.pld-linux.org Git - packages/python-jwzthreading.git/blob - python-jwzthreading.spec
automatic change: use py_build/py_install macros
[packages/python-jwzthreading.git] / python-jwzthreading.spec
1 %define         module  jwzthreading
2 Summary:        Implementation of algorithm for threading mail messages
3 Summary(pl.UTF-8):      Implementacja algorytmu wątkowania wiadomości pocztowych
4 Name:           python-%{module}
5 Version:        0.91
6 Release:        4
7 License:        BSD-like (see LICENSE)
8 Group:          Libraries/Python
9 Source0:        http://www.amk.ca/files/python/%{module}-%{version}.tar.gz
10 # Source0-md5:  567f17b0189d90f570961b8f5d487795
11 URL:            http://www.amk.ca/python/code/jwz.html
12 %pyrequires_eq  python
13 BuildRequires:  python-devel >= 1:2.3
14 BuildRequires:  python-modules
15 BuildRequires:  rpm-pythonprov
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is an implementation of a fast and smart algorithm for threading
21 mail messages, as described by Jamie Zawinski at
22 http://www.jwz.org/doc/threading.html .
23
24 %description -l pl.UTF-8
25 Implementacja szybkiego i sprawnego algorytmu wątkowania poczty,
26 opisana przez Jamie Zawinskiego na stronie
27 http://www.jwz.org/doc/threading.html .
28
29 %prep
30 %setup -q -n %{module}-%{version}
31
32 %build
33 %py_build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
38
39 %py_install
40
41 find $RPM_BUILD_ROOT%{py_sitescriptdir} -type f -name "*.py" -exec rm {} \;
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc LICENSE CHANGES.txt README
49 %{py_sitescriptdir}/%{module}.py?
This page took 0.098032 seconds and 4 git commands to generate.