]> git.pld-linux.org Git - packages/python-joblib.git/blob - python-joblib.spec
- disabled python3 here
[packages/python-joblib.git] / python-joblib.spec
1 # NOTE: for versions >= 0.15.0 for python 3.6+ see python3-joblib.spec
2 # TODO: system modules: cloudpickle, loky
3 #
4 # Conditional build:
5 %bcond_with     doc     # Sphinx documentation (fails on missing examples???)
6 %bcond_without  tests   # unit tests
7 %bcond_without  python2 # CPython 2.x module
8 %bcond_with     python3 # CPython 3.x module (built from python3-joblib.spec)
9
10 Summary:        Lightweight pipelining: using Python functions as pipeline jobs
11 Summary(pl.UTF-8):      Lekkie przetwarzanie potokowe przy użyciu funkcji pythonowych jako zadań
12 Name:           python-joblib
13 # keep 0.14.x here for python2 support
14 Version:        0.14.1
15 Release:        1
16 License:        BSD
17 Group:          Libraries/Python
18 #Source0Download: https://pypi.org/simple/joblib/
19 Source0:        https://files.pythonhosted.org/packages/source/j/joblib/joblib-%{version}.tar.gz
20 # Source0-md5:  182e6bc65681ea49a12775fdc86a8e24
21 URL:            https://pypi.org/project/joblib/
22 %if %{with python2}
23 BuildRequires:  python-modules >= 1:2.7
24 BuildRequires:  python-setuptools
25 %if %{with tests}
26 BuildRequires:  python-pytest
27 %endif
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3-modules >= 1:3.4
31 BuildRequires:  python3-setuptools
32 %if %{with tests}
33 BuildRequires:  python3-pytest
34 BuildRequires:  python3-threadpoolctl
35 %endif
36 %endif
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.714
39 %if %{with doc}
40 BuildRequires:  python3-numpydoc
41 BuildRequires:  python3-sphinx_gallery
42 BuildRequires:  sphinx-pdg-3
43 %endif
44 Requires:       python-modules >= 1:2.7
45 Conflicts:      python-numpy < 1:1.6.1
46 BuildArch:      noarch
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Joblib is a set of tools to provide lightweight pipelining in Python.
51 In particular:
52 - transparent disk-caching of functions and lazy re-evaluation
53    (memoize pattern)
54 - easy simple parallel computing
55         
56 Joblib is optimized to be fast and robust on large data in particular
57 and has specific optimizations for numpy arrays. It is BSD-licensed.
58
59 %description -l pl.UTF-8
60 Joblib to zbiór narzędzi zapewniających lekkie przetwarzanie potokowe
61 w Pythonie. W szczególności:
62 - przezroczyste zapamiętywanie na dysku funkcji i leniwe ponowne
63   wyliczanie (wzorzec memoize)
64 - łatwe, proste przetwarzanie równoległe
65
66 Biblioteka jest zoptymalizowana pod kątem szybkości i funkcjonalności,
67 w szczególności na dużych zbiorach danych; ma wyspecjalizowane
68 optymalizacje dla tablic numpy. Jest na licencji BSD.
69
70 %package -n python3-joblib
71 Summary:        Lightweight pipelining: using Python functions as pipeline jobs
72 Summary(pl.UTF-8):      Lekkie przetwarzanie potokowe przy użyciu funkcji pythonowych jako zadań
73 Group:          Libraries/Python
74 Requires:       python3-modules >= 1:3.4
75 Conflicts:      python3-numpy < 1:1.6.1
76
77 %description -n python3-joblib
78 Joblib is a set of tools to provide lightweight pipelining in Python.
79 In particular:
80 - transparent disk-caching of functions and lazy re-evaluation
81    (memoize pattern)
82 - easy simple parallel computing
83         
84 Joblib is optimized to be fast and robust on large data in particular
85 and has specific optimizations for numpy arrays. It is BSD-licensed.
86
87 %description -n python3-joblib -l pl.UTF-8
88 Joblib to zbiór narzędzi zapewniających lekkie przetwarzanie potokowe
89 w Pythonie. W szczególności:
90 - przezroczyste zapamiętywanie na dysku funkcji i leniwe ponowne
91   wyliczanie (wzorzec memoize)
92 - łatwe, proste przetwarzanie równoległe
93
94 Biblioteka jest zoptymalizowana pod kątem szybkości i funkcjonalności,
95 w szczególności na dużych zbiorach danych; ma wyspecjalizowane
96 optymalizacje dla tablic numpy. Jest na licencji BSD.
97
98 %package apidocs
99 Summary:        API documentation for Python joblib module
100 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona joblib
101 Group:          Documentation
102
103 %description apidocs
104 API documentation for Python joblib module.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API modułu Pythona joblib.
108
109 %prep
110 %setup -q -n joblib-%{version}
111
112 %build
113 %if %{with python2}
114 %py_build
115
116 %if %{with tests}
117 %{__python} -m pytest joblib
118 %endif
119 %endif
120
121 %if %{with python3}
122 %py3_build
123
124 %if %{with tests}
125 # test_pool_memmap_with_big_offset seems unreliable with python3
126 %{__python3} -m pytest joblib -k 'not test_pool_memmap_with_big_offset'
127 %endif
128 %endif
129
130 %if %{with doc}
131 PYTHONPATH=$(pwd) \
132 %{__make} -C doc html \
133         SPHINXBUILD=sphinx-build-3
134 %endif
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %if %{with python2}
140 %py_install
141
142 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/joblib/test
143 %py_postclean
144 %endif
145
146 %if %{with python3}
147 %py3_install
148
149 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/joblib/test
150 %endif
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %if %{with python2}
156 %files
157 %defattr(644,root,root,755)
158 %doc LICENSE.txt README.rst
159 %{py_sitescriptdir}/joblib
160 %{py_sitescriptdir}/joblib-%{version}-py*.egg-info
161 %endif
162
163 %if %{with python3}
164 %files -n python3-joblib
165 %defattr(644,root,root,755)
166 %doc LICENSE.txt README.rst
167 %{py3_sitescriptdir}/joblib
168 %{py3_sitescriptdir}/joblib-%{version}-py*.egg-info
169 %endif
170
171 %if %{with doc}
172 %files apidocs
173 %defattr(644,root,root,755)
174 %doc doc/_build/html/{_static,*.html,*.js}
175 %endif
This page took 0.093947 seconds and 3 git commands to generate.