]> git.pld-linux.org Git - packages/python-joblib.git/blob - python-joblib.spec
0e95e78cb82362ff44ef701ad3c2e3bf99251d2b
[packages/python-joblib.git] / python-joblib.spec
1 # TODO: system modules: cloudpickle, loky
2 #
3 # Conditional build:
4 %bcond_with     doc     # Sphinx documentation (fails on missing examples???)
5 %bcond_without  tests   # unit tests
6 %bcond_without  python2 # CPython 2.x module
7 %bcond_without  python3 # CPython 3.x module
8
9 Summary:        Lightweight pipelining: using Python functions as pipeline jobs
10 Summary(pl.UTF-8):      Lekkie przetwarzanie potokowe przy użyciu funkcji pythonowych jako zadań
11 Name:           python-joblib
12 Version:        0.14.1
13 Release:        1
14 License:        BSD
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/joblib/
17 Source0:        https://files.pythonhosted.org/packages/source/j/joblib/joblib-%{version}.tar.gz
18 # Source0-md5:  182e6bc65681ea49a12775fdc86a8e24
19 URL:            https://pypi.org/project/joblib/
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-pytest
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules >= 1:3.4
29 BuildRequires:  python3-setuptools
30 %if %{with tests}
31 BuildRequires:  python3-pytest
32 BuildRequires:  python3-threadpoolctl
33 %endif
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 %if %{with doc}
38 BuildRequires:  python3-numpydoc
39 BuildRequires:  python3-sphinx_gallery
40 BuildRequires:  sphinx-pdg-3
41 %endif
42 Requires:       python-modules >= 1:2.7
43 Conflicts:      python-numpy < 1:1.6.1
44 BuildArch:      noarch
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Joblib is a set of tools to provide lightweight pipelining in Python.
49 In particular:
50 - transparent disk-caching of functions and lazy re-evaluation
51    (memoize pattern)
52 - easy simple parallel computing
53         
54 Joblib is optimized to be fast and robust on large data in particular
55 and has specific optimizations for numpy arrays. It is BSD-licensed.
56
57 %description -l pl.UTF-8
58 Joblib to zbiór narzędzi zapewniających lekkie przetwarzanie potokowe
59 w Pythonie. W szczególności:
60 - przezroczyste zapamiętywanie na dysku funkcji i leniwe ponowne
61   wyliczanie (wzorzec memoize)
62 - łatwe, proste przetwarzanie równoległe
63
64 Biblioteka jest zoptymalizowana pod kątem szybkości i funkcjonalności,
65 w szczególności na dużych zbiorach danych; ma wyspecjalizowane
66 optymalizacje dla tablic numpy. Jest na licencji BSD.
67
68 %package -n python3-joblib
69 Summary:        Lightweight pipelining: using Python functions as pipeline jobs
70 Summary(pl.UTF-8):      Lekkie przetwarzanie potokowe przy użyciu funkcji pythonowych jako zadań
71 Group:          Libraries/Python
72 Requires:       python3-modules >= 1:3.4
73 Conflicts:      python3-numpy < 1:1.6.1
74
75 %description -n python3-joblib
76 Joblib is a set of tools to provide lightweight pipelining in Python.
77 In particular:
78 - transparent disk-caching of functions and lazy re-evaluation
79    (memoize pattern)
80 - easy simple parallel computing
81         
82 Joblib is optimized to be fast and robust on large data in particular
83 and has specific optimizations for numpy arrays. It is BSD-licensed.
84
85 %description -n python3-joblib -l pl.UTF-8
86 Joblib to zbiór narzędzi zapewniających lekkie przetwarzanie potokowe
87 w Pythonie. W szczególności:
88 - przezroczyste zapamiętywanie na dysku funkcji i leniwe ponowne
89   wyliczanie (wzorzec memoize)
90 - łatwe, proste przetwarzanie równoległe
91
92 Biblioteka jest zoptymalizowana pod kątem szybkości i funkcjonalności,
93 w szczególności na dużych zbiorach danych; ma wyspecjalizowane
94 optymalizacje dla tablic numpy. Jest na licencji BSD.
95
96 %package apidocs
97 Summary:        API documentation for Python joblib module
98 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona joblib
99 Group:          Documentation
100
101 %description apidocs
102 API documentation for Python joblib module.
103
104 %description apidocs -l pl.UTF-8
105 Dokumentacja API modułu Pythona joblib.
106
107 %prep
108 %setup -q -n joblib-%{version}
109
110 %build
111 %if %{with python2}
112 %py_build
113
114 %if %{with tests}
115 %{__python} -m pytest joblib
116 %endif
117 %endif
118
119 %if %{with python3}
120 %py3_build
121
122 %if %{with tests}
123 # test_pool_memmap_with_big_offset seems unreliable with python3
124 %{__python3} -m pytest joblib -k 'not test_pool_memmap_with_big_offset'
125 %endif
126 %endif
127
128 %if %{with doc}
129 PYTHONPATH=$(pwd) \
130 %{__make} -C doc html \
131         SPHINXBUILD=sphinx-build-3
132 %endif
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %if %{with python2}
138 %py_install
139
140 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/joblib/test
141 %py_postclean
142 %endif
143
144 %if %{with python3}
145 %py3_install
146
147 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/joblib/test
148 %endif
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %if %{with python2}
154 %files
155 %defattr(644,root,root,755)
156 %doc LICENSE.txt README.rst
157 %{py_sitescriptdir}/joblib
158 %{py_sitescriptdir}/joblib-%{version}-py*.egg-info
159 %endif
160
161 %if %{with python3}
162 %files -n python3-joblib
163 %defattr(644,root,root,755)
164 %doc LICENSE.txt README.rst
165 %{py3_sitescriptdir}/joblib
166 %{py3_sitescriptdir}/joblib-%{version}-py*.egg-info
167 %endif
168
169 %if %{with doc}
170 %files apidocs
171 %defattr(644,root,root,755)
172 %doc doc/_build/html/{_static,*.html,*.js}
173 %endif
This page took 0.068248 seconds and 2 git commands to generate.