]> git.pld-linux.org Git - packages/python-jinja2.git/blob - python-jinja2.spec
- updated to 2.8
[packages/python-jinja2.git] / python-jinja2.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # API documentation
4 %bcond_without  python2 # Python 2.x modules
5 %bcond_without  python3 # Python 3.x modules
6
7 %define         module  jinja2
8 Summary:        Jinja2 Template engine for Python 2.x
9 Summary(pl.UTF-8):      Silnik szablonów Jinja2 dla Pythona 2.x
10 Name:           python-%{module}
11 Version:        2.8
12 Release:        1
13 License:        BSD
14 Group:          Development/Languages/Python
15 Source0:        https://pypi.python.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
16 # Source0-md5:  edb51693fe22c53cee5403775c71a99e
17 URL:            http://jinja.pocoo.org/
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 BuildRequires:  rpm-pythonprov
20 %if %{with python2}
21 BuildRequires:  python-devel >= 1:2.6
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-devel >= 1:3.3
26 BuildRequires:  python3-modules >= 1:3.3
27 BuildRequires:  python3-setuptools
28 %endif
29 %if %{with doc}
30 BuildRequires:  sphinx-pdg
31 %endif
32 Requires:       python-markupsafe
33 Requires:       python-modules >= 1:2.6
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A small but fast and easy to use stand-alone template engine written
39 in pure Python. Provides a Django inspired non-XML syntax but supports
40 inline expressions and an optional sandboxed environment.
41
42 %description -l pl.UTF-8
43 Mały ale szybki i łatwy w użyciu samodzielny silnik szablonów napisany
44 w czystym Pythonie. Udostępnia podobne do Django, o odmiennej od XML-a
45 składni i kompilowane do kodu Pythona szablony w opcjonalnie
46 ograniczonym środowisku.
47
48 %package -n python3-%{module}
49 Summary:        Template engine Jinja2 for Python 3.x
50 Summary(pl.UTF-8):      Silnik szablonów Jinja2 dla Pythona 3.x
51 Group:          Development/Languages/Python
52 Requires:       python3-markupsafe
53 Requires:       python3-modules >= 1:3.3
54
55 %description -n python3-%{module}
56 A small but fast and easy to use stand-alone template engine written
57 in pure Python. Provides a Django inspired non-XML syntax but supports
58 inline expressions and an optional sandboxed environment.
59
60 %description -n python3-%{module} -l pl.UTF-8
61 Mały ale szybki i łatwy w użyciu samodzielny silnik szablonów napisany
62 w czystym Pythonie. Udostępnia podobne do Django, o odmiennej od XML-a
63 składni i kompilowane do kodu Pythona szablony w opcjonalnie
64 ograniczonym środowisku.
65
66 %package apidoc
67 Summary:        Jinja2 template engine API documentation
68 Summary(pl.UTF-8):      Dokumentacja API silnika szablonów Jinja2
69 Group:          Development/Languages/Python
70
71 %description apidoc
72 API documentation for Jinja2 template engine.
73
74 %description apidoc -l pl.UTF-8
75 Dokumentacja API silnika szablonów Jinja2.
76
77 %prep
78 %setup -q -n Jinja2-%{version}
79
80 %build
81 %if %{with python2}
82 %py_build
83 %endif
84 %if %{with python3}
85 %py3_build
86 %endif
87
88 %if %{with doc}
89 cd docs
90 %{__make} -j1 html
91 %{__rm} -r _build/html/_sources
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %if %{with python2}
98 %py_install
99
100 %py_postclean
101 %endif
102
103 %if %{with python3}
104 %py3_install
105 %endif
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %if %{with python2}
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS CHANGES LICENSE
114 %{py_sitescriptdir}/%{module}
115 %{py_sitescriptdir}/Jinja2-%{version}-py*.egg-info
116 %endif
117
118 %if %{with python3}
119 %files -n python3-%{module}
120 %defattr(644,root,root,755)
121 %doc AUTHORS CHANGES LICENSE
122 %{py3_sitescriptdir}/%{module}
123 %{py3_sitescriptdir}/Jinja2-%{version}-py*.egg-info
124 %endif
125
126 %if %{with doc}
127 %files apidoc
128 %defattr(644,root,root,755)
129 %doc docs/_build/html/*
130 %endif
This page took 0.101831 seconds and 3 git commands to generate.