]> git.pld-linux.org Git - packages/python-jedi.git/blob - python-jedi.spec
- updated to 0.17.2
[packages/python-jedi.git] / python-jedi.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (failing at start as of 0.17.0)
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 Summary:        An autocompletion tool for Python that can be used for text editors
9 Summary(pl.UTF-8):      Narzędzie do automatycznego dopełaniania dla Pythona, nadające się do użycia w edytorach
10 Name:           python-jedi
11 # keep 0.17.x here for python2 support
12 Version:        0.17.2
13 Release:        1
14 License:        MIT (Jedi), Apache v2.0 (typeshed)
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/jedi/
17 Source0:        https://files.pythonhosted.org/packages/source/j/jedi/jedi-%{version}.tar.gz
18 # Source0-md5:  f012668907d76cebe9c4766f3b806fcf
19 URL:            https://pypi.org/project/jedi/
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-colorama
25 BuildRequires:  python-docopt
26 BuildRequires:  python-parso >= 0.7.0
27 BuildRequires:  python-parso < 0.8.0
28 BuildRequires:  python-pytest >= 3.9.0
29 BuildRequires:  python-pytest < 5
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-modules >= 1:3.5
34 BuildRequires:  python3-setuptools
35 %if %{with tests}
36 BuildRequires:  python3-colorama
37 BuildRequires:  python3-docopt
38 BuildRequires:  python3-parso >= 0.7.0
39 BuildRequires:  python3-parso < 0.8.0
40 BuildRequires:  python3-pytest >= 3.9.0
41 BuildRequires:  python3-pytest < 5
42 %endif
43 %endif
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.714
46 %if %{with doc}
47 BuildRequires:  python-parso >= 0.7.0
48 BuildRequires:  sphinx-pdg-2
49 %endif
50 Requires:       python-modules >= 1:2.7
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Jedi is a static analysis tool for Python that is typically used in
56 IDEs/editors plugins. Jedi has a focus on autocompletion and goto
57 functionality. Other features include refactoring, code search and
58 finding references.
59
60 %description -l pl.UTF-8
61 Jedi to narzędzie do statycznej analizy kodu dla Pythona, zwykle
62 używane w IDE i wtyczkach do edytorów. Jedi skupia się na funkcjach
63 automatycznego dopełniania oraz przemieszczania po kodzie. Pozostałe
64 funkcje obejmują refaktorowanie, przeszukiwanie kodu i wyszukiwanie
65 odwołań.
66
67 %package -n python3-jedi
68 Summary:        An autocompletion tool for Python that can be used for text editors
69 Summary(pl.UTF-8):      Narzędzie do automatycznego dopełaniania dla Pythona, nadające się do użycia w edytorach
70 Group:          Libraries/Python
71 Requires:       python3-modules >= 1:3.5
72
73 %description -n python3-jedi
74 Jedi is a static analysis tool for Python that is typically used in
75 IDEs/editors plugins. Jedi has a focus on autocompletion and goto
76 functionality. Other features include refactoring, code search and
77 finding references.
78
79 %description -n python3-jedi -l pl.UTF-8
80 Jedi to narzędzie do statycznej analizy kodu dla Pythona, zwykle
81 używane w IDE i wtyczkach do edytorów. Jedi skupia się na funkcjach
82 automatycznego dopełniania oraz przemieszczania po kodzie. Pozostałe
83 funkcje obejmują refaktorowanie, przeszukiwanie kodu i wyszukiwanie
84 odwołań.
85
86 %package apidocs
87 Summary:        API documentation for Python jedi module
88 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona jedi
89 Group:          Documentation
90
91 %description apidocs
92 API documentation for Python jedi module.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API modułu Pythona jedi.
96
97 %prep
98 %setup -q -n jedi-%{version}
99
100 %build
101 %if %{with python2}
102 %py_build
103
104 %if %{with tests}
105 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
106 %{__python} -m pytest
107 %endif
108 %endif
109
110 %if %{with python3}
111 %py3_build
112
113 %if %{with tests}
114 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
115 %{__python3} -m pytest
116 %endif
117 %endif
118
119 %if %{with doc}
120 %{__make} -C docs html \
121         SPHINXBUILD=sphinx-build-2
122 %endif
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %if %{with python2}
128 %py_install
129
130 %py_postclean
131 %endif
132
133 %if %{with python3}
134 %py3_install
135 %endif
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %if %{with python2}
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS.txt CHANGELOG.rst LICENSE.txt README.rst
144 %{py_sitescriptdir}/jedi
145 %{py_sitescriptdir}/jedi-%{version}-py*.egg-info
146 %endif
147
148 %if %{with python3}
149 %files -n python3-jedi
150 %defattr(644,root,root,755)
151 %doc AUTHORS.txt CHANGELOG.rst LICENSE.txt README.rst
152 %{py3_sitescriptdir}/jedi
153 %{py3_sitescriptdir}/jedi-%{version}-py*.egg-info
154 %endif
155
156 %if %{with doc}
157 %files apidocs
158 %defattr(644,root,root,755)
159 %doc docs/_build/html/{_images,_modules,_static,docs,*.html,*.js}
160 %endif
This page took 0.07913 seconds and 3 git commands to generate.