]> git.pld-linux.org Git - packages/python-gnutls.git/blob - python-gnutls.spec
f4da150c13b23f0abce09ab0c239b21737441c6a
[packages/python-gnutls.git] / python-gnutls.spec
1 %define         module  gnutls
2 Summary:        Python wrapper for the GNUTLS library
3 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki GNUTLS
4 Name:           python-%{module}
5 Version:        2.0.1
6 Release:        2
7 License:        LGPL v2+
8 Group:          Development/Languages/Python
9 Source0:        https://pypi.python.org/packages/source/p/python-gnutls/%{name}-%{version}.tar.gz
10 # Source0-md5:  adba310851a15d19ff29355385c6f74f
11 URL:            https://pypi.python.org/pypi/python-gnutls/
12 BuildRequires:  gnutls-devel >= 3.1.4
13 BuildRequires:  python-devel
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.710
16 Requires:       gnutls >= 3.1.4
17 Requires:       python-modules
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This package provides a high level object oriented wrapper around
22 libgnutls, as well as low level bindings to the GNUTLS types and
23 functions via ctypes. The high level wrapper hides the details of
24 accessing the GNUTLS library via ctypes behind a set of classes that
25 encapsulate GNUTLS sessions, certificates and credentials and expose
26 them to Python applications using a simple API.
27
28 %description -l pl.UTF-8
29 Ten pakiet udostępnia wysokopoziomowe, zorientowane obiektowo
30 obudowanie libgnutls, a także niskopoziomowe wiązania do typów i
31 funkcji GNUTLS poprzez ctypes. Wysokopoziomowe obudowanie skrywa
32 szczegóły dostępu do biblioteki GNUTLS poprzez ctypes za zbiorem klas
33 przechowujących sesje, certyfikaty oraz dane uwierzytelniające GNUTLS
34 i udostępnia je aplikacjom Pythona poprzez proste API.
35
36 %prep
37 %setup -q
38
39 %build
40 %py_build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 %py_install
45
46 %py_postclean
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc ChangeLog LICENSE README
54 %dir %{py_sitescriptdir}/gnutls
55 %{py_sitescriptdir}/gnutls/*.py[co]
56 %dir %{py_sitescriptdir}/gnutls/interfaces
57 %{py_sitescriptdir}/gnutls/interfaces/*.py[co]
58 %dir %{py_sitescriptdir}/gnutls/interfaces/twisted
59 %{py_sitescriptdir}/gnutls/interfaces/twisted/*.py[co]
60 %dir %{py_sitescriptdir}/gnutls/library
61 %{py_sitescriptdir}/gnutls/library/*.py[co]
62 %{py_sitescriptdir}/python_gnutls-%{version}-py*.egg-info
This page took 0.079685 seconds and 2 git commands to generate.