]> git.pld-linux.org Git - packages/python-gnutls.git/blob - python-gnutls.spec
e539047b1ae479f3030d0dda2819758e6e660317
[packages/python-gnutls.git] / python-gnutls.spec
1 %define         module  gnutls
2 Summary:        Python wrapper for the GNUTLS library
3 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki GNUTLS
4 Name:           python-%{module}
5 Version:        3.1.1
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Languages/Python
9 #Source0Download: https://pypi.python.org/simple/python-gnutls/
10 Source0:        https://files.pythonhosted.org/packages/source/p/python-gnutls/%{name}-%{version}.tar.gz
11 # Source0-md5:  c8bcb2b2ded61216b3b6003fc52041ee
12 URL:            https://pypi.python.org/pypi/python-gnutls/
13 BuildRequires:  gnutls-devel >= 3.2.0
14 BuildRequires:  python-devel >= 1:2.7
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 Requires:       gnutls >= 3.2.0
18 Requires:       python-modules >= 1:2.7
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This package provides a high level object oriented wrapper around
23 libgnutls, as well as low level bindings to the GNUTLS types and
24 functions via ctypes. The high level wrapper hides the details of
25 accessing the GNUTLS library via ctypes behind a set of classes that
26 encapsulate GNUTLS sessions, certificates and credentials and expose
27 them to Python applications using a simple API.
28
29 %description -l pl.UTF-8
30 Ten pakiet udostępnia wysokopoziomowe, zorientowane obiektowo
31 obudowanie libgnutls, a także niskopoziomowe wiązania do typów i
32 funkcji GNUTLS poprzez ctypes. Wysokopoziomowe obudowanie skrywa
33 szczegóły dostępu do biblioteki GNUTLS poprzez ctypes za zbiorem klas
34 przechowujących sesje, certyfikaty oraz dane uwierzytelniające GNUTLS
35 i udostępnia je aplikacjom Pythona poprzez proste API.
36
37 %prep
38 %setup -q
39
40 %build
41 %py_build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %py_install
46
47 %py_postclean
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc ChangeLog LICENSE README
55 %dir %{py_sitescriptdir}/gnutls
56 %{py_sitescriptdir}/gnutls/*.py[co]
57 %dir %{py_sitescriptdir}/gnutls/interfaces
58 %{py_sitescriptdir}/gnutls/interfaces/*.py[co]
59 %dir %{py_sitescriptdir}/gnutls/interfaces/twisted
60 %{py_sitescriptdir}/gnutls/interfaces/twisted/*.py[co]
61 %dir %{py_sitescriptdir}/gnutls/library
62 %{py_sitescriptdir}/gnutls/library/*.py[co]
63 %{py_sitescriptdir}/python_gnutls-%{version}-py*.egg-info
This page took 0.055945 seconds and 2 git commands to generate.