]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- verbose .defs files
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygobject_ver   2.17.0
3 %define         pygtk_ver       2:2.16.0
4 %define         pyorbit_ver     2.14.2
5 Summary:        GNOME bindings for Python
6 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek GNOME
7 Name:           python-gnome
8 Version:        2.28.1
9 Release:        12
10 License:        LGPL v2.1+
11 Group:          Libraries/Python
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/%{module}-%{version}.tar.bz2
13 # Source0-md5:  a17ad952813ed86f520de8e07194a2bf
14 BuildRequires:  GConf2-devel >= 2.22.0
15 BuildRequires:  glib2-devel >= 1:2.16.0
16 BuildRequires:  gnome-common >= 2.20.0
17 BuildRequires:  gnome-vfs2-devel >= 2.22.0
18 BuildRequires:  gtk+2-devel >= 2:2.12.0
19 BuildRequires:  libbonobo-devel >= 2.22.0
20 BuildRequires:  libbonoboui-devel >= 2.22.0
21 BuildRequires:  libgnome-devel >= 2.22.0
22 BuildRequires:  libgnomecanvas-devel >= 2.8.0
23 BuildRequires:  libgnomeui-devel >= 2.22.0
24 BuildRequires:  libxslt-progs
25 BuildRequires:  pkgconfig
26 BuildRequires:  popt-devel
27 BuildRequires:  python-devel >= 1:2.3.2
28 BuildRequires:  python-pygobject-devel >= %{pygobject_ver}
29 BuildRequires:  python-pygtk-devel >= %{pygtk_ver}
30 BuildRequires:  python-pyorbit-devel >= %{pyorbit_ver}
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.219
33 BuildRequires:  sed >= 4.0
34 Requires:       %{name}-common = %{version}-%{release}
35 Requires:       libgnome-libs >= 2.22.0
36 Requires:       python-pygobject >= %{pygobject_ver}
37 Obsoletes:      gnome-python
38 Obsoletes:      gnome-python-nautilus
39 Obsoletes:      python-gnome-nautilus
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
43
44 %description
45 GNOME bindings for Python.
46
47 %description -l pl.UTF-8
48 Wiązania Pythona do bibliotek GNOME.
49
50 %package bonobo
51 Summary:        Bonobo bindings for Python
52 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Bonobo
53 Group:          Libraries/Python
54 Requires:       libbonobo >= 2.22.0
55 Requires:       python-pygobject >= %{pygobject_ver}
56 Requires:       python-pyorbit >= %{pyorbit_ver}
57
58 %description bonobo
59 Bonobo bindings for Python.
60
61 %description bonobo -l pl.UTF-8
62 Wiązania Pythona do biblioteki Bonobo.
63
64 %package bonobo-ui
65 Summary:        Bonobo User Interface bindings for Python
66 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki interfejsu użytkownika Bonobo
67 Group:          Libraries/Python
68 Requires:       %{name}-bonobo = %{version}-%{release}
69 Requires:       %{name}-canvas = %{version}-%{release}
70 Requires:       libbonoboui >= 2.22.0
71 Requires:       libgnome-libs >= 2.22.0
72 Requires:       python-pygobject >= %{pygobject_ver}
73 Requires:       python-pygtk-gtk >= %{pygtk_ver}
74
75 %description bonobo-ui
76 Bonobo User Interface bindings for Python.
77
78 %description bonobo-ui -l pl.UTF-8
79 Wiązania Pythona do biblioteki interfejsu użytkownika Bonobo.
80
81 %package canvas
82 Summary:        GNOME Canvas bindings for Python
83 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME Canvas
84 Group:          Libraries/Python
85 Requires:       %{name}-common = %{version}-%{release}
86 Requires:       libgnomecanvas >= 2.8.0
87 Requires:       python-pygobject >= %{pygobject_ver}
88 Requires:       python-pygtk-gtk >= %{pygtk_ver}
89
90 %description canvas
91 GNOME Canvas bindings for Python.
92
93 %description canvas -l pl.UTF-8
94 Wiązania Pythona do biblioteki GNOME Canvas.
95
96 %package gconf
97 Summary:        GConf bindings for Python
98 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GConf
99 Group:          Libraries/Python
100 Requires:       %{name}-common = %{version}-%{release}
101 Requires:       GConf2-libs >= 2.22.0
102 Requires:       python-pygobject >= %{pygobject_ver}
103
104 %description gconf
105 GConf bindings for Python.
106
107 %description gconf -l pl.UTF-8
108 Wiązania Pythona do biblioteki GConf.
109
110 %package ui
111 Summary:        GNOME User Interface bindings for Python
112 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki interfejsu użytkownika GNOME
113 Group:          Libraries/Python
114 Requires:       %{name}-bonobo-ui = %{version}-%{release}
115 Requires:       %{name}-canvas = %{version}-%{release}
116 Requires:       libgnomeui >= 2.22.0
117 Requires:       python-pygobject >= %{pygobject_ver}
118 Requires:       python-pygtk-gtk >= %{pygtk_ver}
119
120 %description ui
121 GNOME User Interface bindings for Python.
122
123 %description ui -l pl.UTF-8
124 Wiązania Pythona do biblioteki interfejsu użytkownika GNOME.
125
126 %package vfs
127 Summary:        GNOME VFS bindings for Python
128 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME VFS
129 Group:          Libraries/Python
130 Requires:       %{name}-common = %{version}-%{release}
131 Requires:       gnome-vfs2-libs >= 2.22.0
132 Requires:       libbonobo >= 2.22.0
133 Requires:       python-pygobject >= %{pygobject_ver}
134 Requires:       python-pyorbit >= %{pyorbit_ver}
135
136 %description vfs
137 GNOME VFS bindings for Python.
138
139 %description vfs -l pl.UTF-8
140 Wiązania Pythona do biblioteki GNOME VFS.
141
142 %package common
143 Summary:        Common files for Python GNOME bindings
144 Summary(pl.UTF-8):      Pliki wspólne wiązań Pythona do GNOME
145 Group:          Libraries/Python
146 Requires:       python-libs >= 1:2.3.2
147 Requires:       python-pygobject >= %{pygobject_ver}
148
149 %description common
150 Common files for Python GNOME bindings.
151
152 %description common -l pl.UTF-8
153 Pliki wspólne wiązań Pythona do GNOME.
154
155 %package devel
156 Summary:        Development files for Python GNOME bindings
157 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do GNOME
158 Group:          Development/Libraries
159 Requires:       %{name} = %{version}-%{release}
160 Requires:       %{name}-bonobo = %{version}-%{release}
161 Requires:       %{name}-bonobo-ui = %{version}-%{release}
162 Requires:       %{name}-canvas = %{version}-%{release}
163 Requires:       %{name}-gconf = %{version}-%{release}
164 Requires:       %{name}-ui = %{version}-%{release}
165 Requires:       %{name}-vfs = %{version}-%{release}
166 Requires:       gnome-vfs2-devel >= 2.22.0
167 Requires:       python-pygtk-devel >= %{pygtk_ver}
168
169 %description devel
170 Development files for Python GNOME bindings.
171
172 %description devel -l pl.UTF-8
173 Pliki programistyczne wiązań Pythona do GNOME.
174
175 %package apidocs
176 Summary:        API documentation for Python GNOME bindings
177 Summary(pl.UTF-8):      Dokumentacja API wiązań Pythona do GNOME
178 Group:          Documentation
179 BuildArch:      noarch
180
181 %description apidocs
182 API documentation for Python GNOME bindings.
183
184 %description apidocs -l pl.UTF-8
185 Dokumentacja API wiązań Pythona do GNOME.
186
187 %package examples
188 Summary:        Example programs for python-gnome
189 Summary(pl.UTF-8):      Przykładowe programy do python-gnome
190 Group:          Libraries/Python
191 Requires:       %{name}-devel = %{version}-%{release}
192
193 %description examples
194 This package contains example programs for python-gnome.
195
196 %description examples -l pl.UTF-8
197 Ten pakiet zawiera przykładowe programy dla python-gnome.
198
199 %prep
200 %setup -q -n %{module}-%{version}
201
202 %{__sed} -i -e 's,${DATADIR}/gtk-doc/html/,%{_gtkdocdir}/,' docs/gnomevfs/wscript
203
204 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
205       examples/*/*.py \
206       examples/*/*/*.py
207
208 %build
209 CC="%{__cc}" \
210 CFLAGS="%{rpmcflags}" \
211 ./waf configure \
212         --prefix %{_prefix} \
213         --libdir %{_libdir}
214 ./waf build \
215         --verbose
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219 ./waf install \
220         --destdir $RPM_BUILD_ROOT
221
222 # waf is sucker, and does not +x executables
223 find $RPM_BUILD_ROOT -name '*.so' | xargs chmod a+rx
224
225 %py_postclean
226
227 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
228 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
229
230 %clean
231 rm -rf $RPM_BUILD_ROOT
232
233 %post   -p /sbin/ldconfig
234 %postun -p /sbin/ldconfig
235
236 %files
237 %defattr(644,root,root,755)
238 %{py_sitedir}/gtk-2.0/gnome/__init__.py[co]
239 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome.so
240
241 %files bonobo
242 %defattr(644,root,root,755)
243 %dir %{py_sitedir}/gtk-2.0/bonobo
244 %{py_sitedir}/gtk-2.0/bonobo/__init__.py[co]
245 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo.so
246 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation.so
247
248 %files bonobo-ui
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui.so
251
252 %files canvas
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas.so
255 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
256
257 %files gconf
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf.so
260
261 %files ui
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui.so
264
265 %files vfs
266 %defattr(644,root,root,755)
267 %dir %{py_sitedir}/gtk-2.0/gnomevfs
268 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs/_gnomevfs.so
269 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs/gnomevfsbonobo.so
270 %{py_sitedir}/gtk-2.0/gnomevfs/__init__.py[co]
271 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
272 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
273
274 %files common
275 %defattr(644,root,root,755)
276 %doc AUTHORS ChangeLog NEWS README
277 %dir %{py_sitedir}/gtk-2.0/gnome
278
279 %files devel
280 %defattr(644,root,root,755)
281 %{_includedir}/gnome-python-2.0
282 %dir %{_datadir}/pygtk/2.0/argtypes
283 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
284 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
285 %{pydefsdir}/bonobo.defs
286 %{pydefsdir}/bonobo-types.defs
287 %{pydefsdir}/bonoboui.defs
288 %{pydefsdir}/bonoboui-types.defs
289 %{pydefsdir}/canvas.defs
290 %{pydefsdir}/gconf.defs
291 %{pydefsdir}/gnome.defs
292 %{pydefsdir}/gnome-types.defs
293 %{pydefsdir}/ui.defs
294 %{_pkgconfigdir}/gnome-python-2.0.pc
295
296 %files apidocs
297 %defattr(644,root,root,755)
298 %{_gtkdocdir}/pygnomevfs
299
300 %files examples
301 %defattr(644,root,root,755)
302 %{_examplesdir}/%{name}-%{version}
This page took 0.179787 seconds and 3 git commands to generate.