]> git.pld-linux.org Git - packages/python-gnome-desktop.git/blob - python-gnome-desktop.spec
ff78c11f2fd5b14b414108c18a31b8180a5742de
[packages/python-gnome-desktop.git] / python-gnome-desktop.spec
1 #
2 # NOTE: evince, brasero and mediaprofiles are disabled because these things have
3 # been ported to GTK+3. It's not practical to mix GTK+2 and GTK+3 bindings
4 # in gnome-python2-desktop, so for now we'll just have to disable the GTK+3
5 # stuff.
6 #
7 # Conditional builds:
8 %bcond_without  totem           # totem-plparser support
9
10 %define         module                  gnome-python-desktop
11 %define         pygtk_req               2:2.12.0
12 %define         gnome_python_req        2.26.0
13 Summary:        GNOME bindings for Python
14 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek GNOME
15 Name:           python-gnome-desktop
16 Version:        2.32.0
17 Release:        15
18 License:        GPL v2/LGPL v2.1 (see COPYING)
19 Group:          Libraries/Python
20 Source0:        https://download.gnome.org/sources/gnome-python-desktop/2.32/%{module}-%{version}.tar.bz2
21 # Source0-md5:  0e73fa80ace5c861777e0b523c6ead9d
22 Patch0:         %{name}-gtksourceview.patch
23 Patch1:         %{name}-ac.patch
24 URL:            https://www.gnome.org/
25 BuildRequires:  GConf2-devel >= 2.22.0
26 BuildRequires:  autoconf >= 2.53
27 BuildRequires:  automake
28 BuildRequires:  gnome-common
29 BuildRequires:  gnome-desktop2-devel >= 2.10.0
30 BuildRequires:  gnome-vfs2-devel >= 2.22.0
31 BuildRequires:  gtk+2-devel >= 2:2.12.0
32 BuildRequires:  gtksourceview-devel >= 1.8.4
33 BuildRequires:  libgnome-keyring-devel >= 2.22.0
34 BuildRequires:  libgnomeprintui-devel >= 2.18.1
35 BuildRequires:  libgnomeui-devel
36 BuildRequires:  libgtop-devel >= 2.22.0
37 BuildRequires:  librsvg-devel >= 1:2.22.0
38 BuildRequires:  libtool
39 BuildRequires:  libwnck2-devel >= 2.22.0
40 BuildRequires:  pkgconfig
41 BuildRequires:  python-devel >= 1:2.3.2
42 BuildRequires:  python-gnome-devel >= %{gnome_python_req}
43 BuildRequires:  python-pycairo-devel
44 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
45 BuildRequires:  rpm-build >= 4.6
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.336
48 BuildRequires:  sed >= 4.0
49 %{?with_totem:BuildRequires:    totem-pl-parser-devel >= 1.6.0}
50 Requires:       python-modules
51 Obsoletes:      python-evolution < 0.1
52 Obsoletes:      python-gnome-applet < 2.10.0
53 Obsoletes:      python-gnome-desktop-applet < 2.32.0-4
54 Obsoletes:      python-gnome-desktop-brasero < 2.32.0-4
55 Obsoletes:      python-gnome-desktop-evince < 2.32.0-4
56 Obsoletes:      python-gnome-desktop-evolution < 2.32.0-8
57 Obsoletes:      python-gnome-desktop-mediaprofiles < 2.32.0-4
58 Obsoletes:      python-gnome-desktop-nautilus-cd-burner < 2.30.0-2
59 Obsoletes:      python-gnome-extras-applet < 2.14.0
60 Obsoletes:      python-gnome-extras-mediaprofiles < 2.14.0
61 Obsoletes:      python-gnome-extras-nautilus-cd-burner < 2.14.0
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
65
66 %description
67 GNOME bindings for Python.
68
69 %description -l pl.UTF-8
70 Wiązania Pythona do bibliotek GNOME.
71
72 %package devel
73 Summary:        Development files for GNOME bindings for Python
74 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do GNOME
75 Group:          Libraries/Python
76 Requires:       %{name}-libwnck = %{version}-%{release}
77 Requires:       %{name}-print = %{version}-%{release}
78 Requires:       python-gnome-devel >= %{gnome_python_req}
79 Requires:       python-pygtk-devel >= %{pygtk_req}
80 Obsoletes:      python-gnome-extras-devel < 2.13.3
81
82 %description devel
83 Development files for GNOME bindings for Python.
84
85 %description devel -l pl.UTF-8
86 Pliki programistyczne wiązań Pythona do GNOME.
87
88 %package apidocs
89 Summary:        GNOME bindings for Python API documentation
90 Summary(pl.UTF-8):      Dokumentacja API wiązań Pythona do GNOME
91 Group:          Documentation
92 Requires:       gtk-doc-common
93 BuildArch:      noarch
94
95 %description apidocs
96 GNOME bindings for Python API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API wiązań Pythona do GNOME.
100
101 %package examples
102 Summary:        Example programs for python-gnome-desktop
103 Summary(pl.UTF-8):      Przykładowe programy do python-gnome-desktop
104 Group:          Libraries/Python
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description examples
108 This package contains example programs for python-gnome-desktop.
109
110 %description examples -l pl.UTF-8
111 Ten pakiet zawiera przykładowe programy dla python-gnome-desktop.
112
113 %package gtksourceview
114 Summary:        Gtksourceview bindings for Python
115 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki gtksourceview
116 Group:          Libraries/Python
117 Requires:       %{name}-print = %{version}-%{release}
118 Obsoletes:      python-gnome-extras-gtksourceview < 2.14.0
119
120 %description gtksourceview
121 Gtksourceview bindings for Python.
122
123 %description gtksourceview -l pl.UTF-8
124 Wiązania Pythona do biblioteki gtksourceview.
125
126 %package keyring
127 Summary:        GNOME keyring bindings for Python
128 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME keyring
129 Group:          Libraries/Python
130 Requires:       python-pygobject >= 2.14.0
131
132 %description keyring
133 GNOME keyring bindings for Python.
134
135 %description keyring -l pl.UTF-8
136 Wiązania Pythona do biblioteki GNOME keyring.
137
138 %package libgtop
139 Summary:        Libgtop bindings for Python
140 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libgtop
141 Group:          Libraries/Python
142 Requires:       python-pygobject >= 2.14.0
143 Obsoletes:      python-gnome-extras-libgtop < 2.14.0
144
145 %description libgtop
146 Libgtop bindings for Python.
147
148 %description libgtop -l pl.UTF-8
149 Wiązania Pythona do biblioteki libgtop.
150
151 %package librsvg
152 Summary:        Librsvg bindings for Python
153 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki librsvg
154 Group:          Libraries/Python
155 Requires:       librsvg >= 1:2.22.0
156
157 %description librsvg
158 Librsvg bindings for Python.
159
160 %description librsvg -l pl.UTF-8
161 Wiązania Pythona do biblioteki librsvg.
162
163 %package libwnck
164 Summary:        Libwnck bindings for Python
165 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libwnck
166 Group:          Libraries/Python
167 Requires:       python-pygtk-gtk >= %{pygtk_req}
168 Obsoletes:      python-gnome-extras-libwnck < 2.14.0
169
170 %description libwnck
171 Libwnck bindings for Python.
172
173 %description libwnck -l pl.UTF-8
174 Wiązania Pythona do biblioteki libwnck.
175
176 %package print
177 Summary:        GNOME Print bindings for Python
178 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME obsługi drukowania
179 Group:          Libraries/Python
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       python-gnome-canvas >= %{gnome_python_req}
182 Provides:       python-gnome-print
183 Provides:       python-gnome-print-ui
184 Obsoletes:      python-gnome-extras-print < 2.14.0
185 Obsoletes:      python-gnome-print < 2.10.0
186 Obsoletes:      python-gnome-print-ui < 2.10.0
187
188 %description print
189 GNOME Print bindings for Python.
190
191 %description print -l pl.UTF-8
192 Wiązania Pythona do biblioteki GNOME obsługi drukowania.
193
194 %package totem
195 Summary:        Totem bindings for Python
196 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki totem
197 Group:          Libraries/Python
198 # imported in plparsermodule.c
199 Requires:       python-gnome-vfs >= %{gnome_python_req}
200 # pygtk is redundant here? (pygobject should be enough, but pygtk/pygdk is used in build and gtk linked in)
201 Requires:       python-pygtk-gtk >= %{pygtk_req}
202 Obsoletes:      python-gnome-extras-totem < 2.14.0
203
204 %description totem
205 Totem bindings for Python.
206
207 %description totem -l pl.UTF-8
208 Wiązania Pythona do biblioteki totem.
209
210 %prep
211 %setup -q -n %{module}-%{version}
212 %patch0 -p1
213 %patch1 -p1
214
215 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
216         examples/keyring.py \
217         examples/applet/applet.py \
218         examples/gnomeprint/{example_*,test-print}.py \
219         examples/mediaprofiles/profiles.py
220
221 %build
222 %{__libtoolize}
223 %{__aclocal}
224 %{__autoconf}
225 %{__autoheader}
226 %{__automake}
227 %configure \
228         --disable-applet \
229         --disable-braseromedia \
230         --disable-braseroburn \
231         --disable-bugbuddy \
232         --disable-evolution \
233         --disable-evolution_ecal \
234         --disable-evince \
235         --disable-mediaprofiles \
236         --disable-nautilusburn
237
238 %{__make}
239
240 %install
241 rm -rf $RPM_BUILD_ROOT
242 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
243
244 %{__make} install \
245         DESTDIR=$RPM_BUILD_ROOT \
246         HTML_DIR=%{_gtkdocdir}
247
248 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0
249 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0
250 %py_postclean
251
252 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
253
254 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/*.la}
255
256 %clean
257 rm -rf $RPM_BUILD_ROOT
258
259 %files
260 %defattr(644,root,root,755)
261 %doc AUTHORS COPYING ChangeLog NEWS
262 %dir %{py_sitedir}/gtk-2.0/gnomedesktop
263 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomedesktop/_gnomedesktop.so
264 %{py_sitedir}/gtk-2.0/gnomedesktop/__init__.py[co]
265
266 %files devel
267 %defattr(644,root,root,755)
268 %{pydefsdir}/_gnomedesktop.defs
269 %{pydefsdir}/art.defs
270 %{pydefsdir}/gnomekeyring.defs
271 %{pydefsdir}/gtksourceview.defs
272 %{pydefsdir}/print.defs
273 %{pydefsdir}/printui.defs
274 %{pydefsdir}/wnck.defs
275 %{_pkgconfigdir}/gnome-python-desktop-2.0.pc
276
277 %files apidocs
278 %defattr(644,root,root,755)
279 %{_gtkdocdir}/pygnomeprint
280 %{_gtkdocdir}/pygnomeprintui
281 %{_gtkdocdir}/pygtksourceview
282
283 %files examples
284 %defattr(644,root,root,755)
285 %{_examplesdir}/%{name}-%{version}
286
287 %files gtksourceview
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gtksourceview.so
290
291 %files keyring
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomekeyring.so
294
295 %files libgtop
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gtop.so
298
299 %files librsvg
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{py_sitedir}/gtk-2.0/rsvg.so
302
303 %files libwnck
304 %defattr(644,root,root,755)
305 %attr(755,root,root) %{py_sitedir}/gtk-2.0/wnck.so
306
307 %files print
308 %defattr(644,root,root,755)
309 %dir %{py_sitedir}/gtk-2.0/gnomeprint
310 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomeprint/_print.so
311 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomeprint/ui.so
312 %{py_sitedir}/gtk-2.0/gnomeprint/__init__.py[co]
313
314 %if %{with totem}
315 %files totem
316 %defattr(644,root,root,755)
317 %dir %{py_sitedir}/gtk-2.0/totem
318 %attr(755,root,root) %{py_sitedir}/gtk-2.0/totem/plparser.so
319 %{py_sitedir}/gtk-2.0/totem/__init__.py[co]
320 %endif
This page took 0.102063 seconds and 2 git commands to generate.